summaryrefslogtreecommitdiff
path: root/dev-python/tld/tld-0.12.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-02 03:06:27 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-02 03:06:27 +0000
commitc8273339188289fe8571e5a8cb9e00e59a46aaaf (patch)
tree793a97e856b00e8c923cb6b505ea175f89b35cf2 /dev-python/tld/tld-0.12.6.ebuild
parent60f657b5e6155f26601c7def7baa11cee72246d0 (diff)
gentoo auto-resync : 02:02:2023 - 03:06:27
Diffstat (limited to 'dev-python/tld/tld-0.12.6.ebuild')
-rw-r--r--dev-python/tld/tld-0.12.6.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/dev-python/tld/tld-0.12.6.ebuild b/dev-python/tld/tld-0.12.6.ebuild
index 1a3c41e8bfe3..c580627f61d9 100644
--- a/dev-python/tld/tld-0.12.6.ebuild
+++ b/dev-python/tld/tld-0.12.6.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{9..10} )
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
inherit distutils-r1
DESCRIPTION="Extract the top level domain (TLD) from the URL given"
@@ -13,13 +14,12 @@ SRC_URI="https://github.com/barseghyanartur/${PN}/archive/${PV}.tar.gz -> ${P}.t
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="test !test? ( test )"
-BDEPEND="
- test? (
- dev-python/Faker[${PYTHON_USEDEP}]
- )"
+BDEPEND="test? ( dev-python/Faker[${PYTHON_USEDEP}] )"
-distutils_enable_tests --install pytest
+distutils_enable_tests pytest
src_prepare() {
distutils-r1_src_prepare