summaryrefslogtreecommitdiff
path: root/dev-python/time-machine
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-01 08:21:34 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-01 08:21:34 +0000
commit1581db777aa413144ae9aaff70602eae670c8b93 (patch)
treeadb2d2c6f2a5f0843b82a50ceb35f9f286924c4e /dev-python/time-machine
parentd682a95de35077b0728025627e082b67339fa249 (diff)
gentoo auto-resync : 01:01:2023 - 08:21:34
Diffstat (limited to 'dev-python/time-machine')
-rw-r--r--dev-python/time-machine/Manifest2
-rw-r--r--dev-python/time-machine/time-machine-2.9.0.ebuild36
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/time-machine/Manifest b/dev-python/time-machine/Manifest
index ca91735e690b..73a82d013505 100644
--- a/dev-python/time-machine/Manifest
+++ b/dev-python/time-machine/Manifest
@@ -1,3 +1,5 @@
DIST time-machine-2.8.2.gh.tar.gz 27856 BLAKE2B 2669bacfc7fb9d10186d6053ee155ca7dd28ec3da688971baa371eb8e095a8694e955797bdf1b556056e79277d46c2382dd06979d8e960da5731c3710018e445 SHA512 f49442fe2b846676abca15a9e7231a4b59e8d520482a4ef2294eac9a4e2c0866836d6bd9bec42202bf5f9e94766e9c2a00d4f7c6eb76d5cbc8a702fceef4294c
+DIST time-machine-2.9.0.gh.tar.gz 28043 BLAKE2B 9a9a521c94b72a7464853661da791b6f57f5155ddc62ffceeb82f808903f4c337e6bf48fe8300bb4f9f5673fd175fd85038a4e80a39e8f3e096c12c27ee790ec SHA512 ecc780a72d279b49d026a8f3f89210cb4c90e02c5a517c08eadbabcb65216a24c603ace39afd76ea1e6ccdef589d5997581d0db7477bb28fe4d1e0510daf17a0
EBUILD time-machine-2.8.2.ebuild 687 BLAKE2B fb236f8ea30cd29ebea90d27c3efbdcd683a8007a4739da7e444819fcaef180579ece0f8c4208c60e4489eeee9a8e7d7c909ce24dbf1df968a621591259bfe05 SHA512 04d24ede235a461cce6b4c0932a1df56578dbeec9dc37f9537e85141ef22afca15048e2d230c62ea8eecaee22a4a0f6b510db8f69ae2d74d5a6181f6e5e0870f
+EBUILD time-machine-2.9.0.ebuild 692 BLAKE2B 02388c648da4668aca881e4a917cbafcbcfbc1d16abc7131095d0881cffffd50e8c52ce5c5b9b6736f60420986c796b8d60039050f42fdc023050da3730c7423 SHA512 f9d28bbee97efebea061a89fd081b7a3908a4ed5171cd4a27c1d0085d15931a2dfbe9bf789d762ee8ecd631e73559c956e6f18767ea67db2ddb826a89620423b
MISC metadata.xml 379 BLAKE2B 98883d810d13745555166c9901f0ac15bd1ace4754e67ddb090983d97808a8362f61d91e82e7c903920cf42037c3df2655b211caaff904fb3ac4d2494ebf2fd3 SHA512 74d7de420c0bc5c03a3524bfe9b888fec8e5ec353d89b8a8e5d5d2dbd736ef8d34c45f026fe493dfe87ebcc7754c30d9b3ef7fda1abea91cbf9599bdeb4ed3c9
diff --git a/dev-python/time-machine/time-machine-2.9.0.ebuild b/dev-python/time-machine/time-machine-2.9.0.ebuild
new file mode 100644
index 000000000000..a526c33dc380
--- /dev/null
+++ b/dev-python/time-machine/time-machine-2.9.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Travel through time in your tests"
+HOMEPAGE="
+ https://github.com/adamchainz/time-machine/
+ https://pypi.org/project/time-machine/
+"
+SRC_URI="
+ https://github.com/adamchainz/time-machine/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc"
+
+RDEPEND="
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/backports-zoneinfo[${PYTHON_USEDEP}]
+ ' 3.8)
+ )
+"
+
+distutils_enable_tests pytest