summaryrefslogtreecommitdiff
path: root/dev-python/tikzplotlib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-17 01:16:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-17 01:16:38 +0000
commit53cba99042fa967e2a93da9f8db806fe2d035543 (patch)
tree9780d3b87dfc6bdebc6b7b7d15af1ecb813c6853 /dev-python/tikzplotlib
parent71deace00d1a2b091313fe137ab7092418c6f87c (diff)
gentoo resync : 17.02.2020
Diffstat (limited to 'dev-python/tikzplotlib')
-rw-r--r--dev-python/tikzplotlib/Manifest3
-rw-r--r--dev-python/tikzplotlib/metadata.xml13
-rw-r--r--dev-python/tikzplotlib/tikzplotlib-0.9.1.ebuild42
3 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/tikzplotlib/Manifest b/dev-python/tikzplotlib/Manifest
new file mode 100644
index 000000000000..88b10b1f4022
--- /dev/null
+++ b/dev-python/tikzplotlib/Manifest
@@ -0,0 +1,3 @@
+DIST tikzplotlib-0.9.1.tar.gz 584961 BLAKE2B 62737db9117c96484de690b26c3f13d5a872a3c70ad4ebe635bcba348dfa7f0eb944b8c469807c4c474351a9fae7db6dd71df82e33ee33cbdd8b1abeb9686e1b SHA512 10f3be8b843ea81d48bd6fad494a7e7a0cc5afd45a96c26be7f4dfbac929bdb3010fd355c6e1ef262273fd0783fc5b5b4a7b41a0c01e18cff5446bb9d96ee2b7
+EBUILD tikzplotlib-0.9.1.ebuild 964 BLAKE2B 505f641e86728fc3dd84beded42b8be778b9d5ce43d9d7c7db52bfea0bc3ae71199a7f2726c819dea1378482f6ac4b6545aafeffb8e6385caeb96a14b1051c18 SHA512 d209209143f2195f8d415a640902a145fa6503e2a8dc3d1566da994821d2fc91f13aa8584ee7dc63b6a2e2e6057de0b0a92355d21df523bc6830d7cd1d242c8e
+MISC metadata.xml 841 BLAKE2B c48fa9e38e55f5cf06293ec648491a2824c1f27c0bef31f69a59307b2d42ca1fc1e7ebaec524d01329191250afc4d766e69c2a9a8323cf48c3b31e8fbfc9f8ee SHA512 e69af74f46343c192187cb7ea178c169651ea4d7f40e264d556fcf319a2a24cdaca94629f75b428e543fd4911e5269f25e0fba358dac61ac07cea6ebbc9c4d78
diff --git a/dev-python/tikzplotlib/metadata.xml b/dev-python/tikzplotlib/metadata.xml
new file mode 100644
index 000000000000..50a33145b076
--- /dev/null
+++ b/dev-python/tikzplotlib/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription>tikzplotlib is a Python tool for converting matplotlib figures into PGFPlots (TikZ) figures like for native inclusion into LaTeX documents. The output of tikzplotlib is in PGFPlots, a LaTeX library that sits on top of TikZ and describes graphs in terms of axes, data etc. Consequently, the output of tikzplotlib retains more information, can be more easily understood, and is more easily editable than raw TikZ output.</longdescription>
+ <upstream>
+ <remote-id type="github">nschloe/tikzplotlib</remote-id>
+ <remote-id type="pypi">tikzplotlib</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/tikzplotlib/tikzplotlib-0.9.1.ebuild b/dev-python/tikzplotlib/tikzplotlib-0.9.1.ebuild
new file mode 100644
index 000000000000..9bd714fa2fe7
--- /dev/null
+++ b/dev-python/tikzplotlib/tikzplotlib-0.9.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Convert matplotlib figures into TikZ/PGFPlots"
+HOMEPAGE="https://github.com/nschloe/tikzplotlib"
+SRC_URI="https://github.com/nschloe/tikzplotlib/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]"
+
+DEPEND="test? (
+ dev-python/pandas[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc dev-python/mock
+
+python_prepare_all() {
+ # this test fails: tikz error
+ # cannot mix dimensions and dimensionless values in an ellipse
+ rm test/test_patches.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x MPLBACKEND=Agg
+ virtx pytest -vv
+}