summaryrefslogtreecommitdiff
path: root/dev-python/tikzplotlib/tikzplotlib-0.9.11.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
commit46eedbedafdb0040c37884982d4c775ce277fb7b (patch)
treedb33a91259730be84999e13a8d8168c799f50ac0 /dev-python/tikzplotlib/tikzplotlib-0.9.11.ebuild
parente23a08d0c97a0cc415aaa165da840b056f93c997 (diff)
gentoo resync : 20.10.2021
Diffstat (limited to 'dev-python/tikzplotlib/tikzplotlib-0.9.11.ebuild')
-rw-r--r--dev-python/tikzplotlib/tikzplotlib-0.9.11.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/dev-python/tikzplotlib/tikzplotlib-0.9.11.ebuild b/dev-python/tikzplotlib/tikzplotlib-0.9.11.ebuild
deleted file mode 100644
index be7409c6cc0e..000000000000
--- a/dev-python/tikzplotlib/tikzplotlib-0.9.11.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 2019-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=pyproject.toml
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1 virtualx
-
-DESCRIPTION="Convert matplotlib figures into TikZ/PGFPlots"
-HOMEPAGE="https://github.com/nschloe/tikzplotlib"
-SRC_URI="
- https://github.com/nschloe/${PN}/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- app-text/texlive[extra]
- dev-python/matplotlib[latex,${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/pillow[${PYTHON_USEDEP}]
-"
-
-BDEPEND="
- dev-python/wheel[${PYTHON_USEDEP}]
- test? (
- dev-python/exdown[${PYTHON_USEDEP}]
- dev-python/pandas[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]
-)"
-
-distutils_enable_tests pytest
-distutils_enable_sphinx doc dev-python/mock
-
-python_test() {
- local -x MPLBACKEND=Agg
- local deselect=(
- tests/test_barchart_errorbars.py::test
- tests/test_colorbars.py::test
- tests/test_fillstyle.py::test
- )
-
- virtx epytest ${deselect[@]/#/--deselect }
-}