summaryrefslogtreecommitdiff
path: root/dev-python/tifffile
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
commite68d405c5d712af4387159df07e226217bdda049 (patch)
tree009ab0f3d427f0813e62930d71802cb054c07e30 /dev-python/tifffile
parent401101f9c8077911929d3f2b60a37098460a5d89 (diff)
gentoo resync : 06.04.2022
Diffstat (limited to 'dev-python/tifffile')
-rw-r--r--dev-python/tifffile/Manifest2
-rw-r--r--dev-python/tifffile/tifffile-2022.3.25.ebuild52
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/tifffile/Manifest b/dev-python/tifffile/Manifest
index b348071ce7c8..24fe96e96c1f 100644
--- a/dev-python/tifffile/Manifest
+++ b/dev-python/tifffile/Manifest
@@ -1,3 +1,5 @@
DIST tifffile-2022.3.16.gh.tar.gz 263653 BLAKE2B fcd30e2fd38a12438332badb17e937ab095a8088f9c878b84166a67c7486f436a76d39832df22362f7a74de5da537602da82c982fb4dc0699fba1603adefdcef SHA512 8069a87b241cbb11b3efa8ff679106f2f11ff9045d790fb1612076a60b87791f30afffb55b57d19b70ab4441935f418ad91fb0956ab572890704023e63dea84a
+DIST tifffile-2022.3.25.gh.tar.gz 265082 BLAKE2B dd5f3705cb7203fe943b97a5ed5c000b44abf48ec748f38a1468e27e82bd980e4100dd14af5cfd6af5bdee9d0036c5dce37efca1e515f2eb283c0e221150915a SHA512 dc9018991989ca4b89be6f315aaa45ff2fb94c504dd4c1790af1ec68e05a1da85560f5098df2f460b726cea0d4b0e4fc3f12d493dc1a1db8e2cc35d86f547ddf
EBUILD tifffile-2022.3.16.ebuild 1269 BLAKE2B 95a1bc97800e704cce4b621fb47933d4eaa4f12338ef912dc3a3f75ca49d622a27371f30bb40295f04ea1ad421f55787fc1087533ba256bb01f75d31264cfd77 SHA512 b84b2b9b77d23e2c7fb322e38437f6704f92dcec6c3ab7c71153f3982a339ac9b4fe8c96462cbe76898d78c6ec33bb9199f23f78e129e485ff9aba14c0acf310
+EBUILD tifffile-2022.3.25.ebuild 1269 BLAKE2B 95a1bc97800e704cce4b621fb47933d4eaa4f12338ef912dc3a3f75ca49d622a27371f30bb40295f04ea1ad421f55787fc1087533ba256bb01f75d31264cfd77 SHA512 b84b2b9b77d23e2c7fb322e38437f6704f92dcec6c3ab7c71153f3982a339ac9b4fe8c96462cbe76898d78c6ec33bb9199f23f78e129e485ff9aba14c0acf310
MISC metadata.xml 346 BLAKE2B 8cecb51fe01826a2a190c4e3020836f5706a918515a3ef5b4624fc3e9985411a8fd3c261fb7b6d8ad4f4486164487d11bdc2b071eeb5a95083db4c5323ae2dbe SHA512 81f8f6f5231d6cc9a8e7f95416a63cc52027f58fa54ce16bacfaa0ae285a48c5a3850d83d5ab50ca89be248ce386528db32811b23d61fa0d0e1e0cc737150465
diff --git a/dev-python/tifffile/tifffile-2022.3.25.ebuild b/dev-python/tifffile/tifffile-2022.3.25.ebuild
new file mode 100644
index 000000000000..bcfdee9f5d5f
--- /dev/null
+++ b/dev-python/tifffile/tifffile-2022.3.25.ebuild
@@ -0,0 +1,52 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Read and write TIFF files"
+HOMEPAGE="
+ https://pypi.org/project/tifffile/
+ https://github.com/cgohlke/tifffile/
+ https://www.lfd.uci.edu/~gohlke/
+"
+SRC_URI="
+ https://github.com/cgohlke/tifffile/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/numpy-1.19.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/dask[${PYTHON_USEDEP}]
+ >=dev-python/fsspec-2021.5.0[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Internet
+ tests/test_tifffile.py::test_class_omexml
+ tests/test_tifffile.py::test_class_omexml_fail
+ tests/test_tifffile.py::test_class_omexml_modulo
+ tests/test_tifffile.py::test_class_omexml_attributes
+ tests/test_tifffile.py::test_class_omexml_multiimage
+ tests/test_tifffile.py::test_write_ome
+ tests/test_tifffile.py::test_write_ome_manual
+ # requires tons of free space
+ tests/test_tifffile.py::test_write_3gb
+ tests/test_tifffile.py::test_write_bigtiff
+ 'tests/test_tifffile.py::test_write_imagej_raw'
+)