summaryrefslogtreecommitdiff
path: root/dev-python/tifffile
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-21 07:53:35 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-21 07:53:35 +0000
commite393c0503a79342594a61547dc43f80f8bcc086e (patch)
tree3254e8166c98b932add34913169c98f7b7f9fa5f /dev-python/tifffile
parentb46782805d0eed36ce9685f7e9abf25671f24d7d (diff)
gentoo auto-resync : 21:12:2022 - 07:53:34
Diffstat (limited to 'dev-python/tifffile')
-rw-r--r--dev-python/tifffile/Manifest1
-rw-r--r--dev-python/tifffile/tifffile-2022.10.10-r1.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/tifffile/Manifest b/dev-python/tifffile/Manifest
index 5734cc8620a6..e6c387c044a7 100644
--- a/dev-python/tifffile/Manifest
+++ b/dev-python/tifffile/Manifest
@@ -1,3 +1,4 @@
DIST tifffile-2022.10.10.gh.tar.gz 315965 BLAKE2B 9f1d5c37062fd2fd2c30411b479d77977d387e4df19ae795fba085179f7ad0e3dfafa6068ccc895586f59a2437a1203748b3e1bbeb0f4a2d433728c2e79fc47a SHA512 7ccd6b4b802e63ca2646ea4f716fb16f02a091042c02d200c7a6756dc06a60d7d165aa5fefc63db954e60dcaf6bf8626349de7e4b836394b70df7ee71ec28790
+EBUILD tifffile-2022.10.10-r1.ebuild 1424 BLAKE2B ce6678d2af8e80d05d39302422d9b8c16be8e719f67de0983461185979091eb7900ccde86fb36eb06e6858ce2771c679ec809a6e4c964906df9bc97c5548ff0f SHA512 d2de577d3ac4a91c2a3797b8e8a8476d743969c2397fbdd7fa36e117d76663d53dd5a08ba2bb7369ec7763583c0d4b89048406539943a916046dc91d0e69eeba
EBUILD tifffile-2022.10.10.ebuild 1423 BLAKE2B b4ced7553115bcaed97d865253b1d4cce3f1c07da348a186d3f4a6c68838dbb283cdea148f3096d6f2f41b00ee4d6d65f06938b245698dd5bc52c61668b82dca SHA512 15ad933a3738a7ca176ba2f4cae6bf2955d7ec1d3d56d9375d9e66576bb4979f469f7a05316ad35ccf336432966f2dcd7e73603d57ab3147aaec20165973153d
MISC metadata.xml 346 BLAKE2B 8cecb51fe01826a2a190c4e3020836f5706a918515a3ef5b4624fc3e9985411a8fd3c261fb7b6d8ad4f4486164487d11bdc2b071eeb5a95083db4c5323ae2dbe SHA512 81f8f6f5231d6cc9a8e7f95416a63cc52027f58fa54ce16bacfaa0ae285a48c5a3850d83d5ab50ca89be248ce386528db32811b23d61fa0d0e1e0cc737150465
diff --git a/dev-python/tifffile/tifffile-2022.10.10-r1.ebuild b/dev-python/tifffile/tifffile-2022.10.10-r1.ebuild
new file mode 100644
index 000000000000..29da3b3c468d
--- /dev/null
+++ b/dev-python/tifffile/tifffile-2022.10.10-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Read and write TIFF files"
+HOMEPAGE="
+ https://pypi.org/project/tifffile/
+ https://github.com/cgohlke/tifffile/
+ https://www.cgohlke.com/
+"
+SRC_URI="
+ https://github.com/cgohlke/tifffile/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/numpy-1.19.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/dask[${PYTHON_USEDEP}]
+ >=dev-python/fsspec-2021.5.0[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/xarray[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Internet
+ tests/test_tifffile.py::test_class_omexml
+ tests/test_tifffile.py::test_class_omexml_fail
+ tests/test_tifffile.py::test_class_omexml_modulo
+ tests/test_tifffile.py::test_class_omexml_attributes
+ tests/test_tifffile.py::test_class_omexml_multiimage
+ tests/test_tifffile.py::test_write_ome
+ tests/test_tifffile.py::test_write_ome_manual
+ # requires tons of free space
+ tests/test_tifffile.py::test_write_3gb
+ tests/test_tifffile.py::test_write_bigtiff
+ 'tests/test_tifffile.py::test_write_imagej_raw'
+ # TODO
+ tests/test_tifffile.py::test_issue_imagej_hyperstack_arg
+ tests/test_tifffile.py::test_issue_description_overwrite
+)