summaryrefslogtreecommitdiff
path: root/dev-python/tifffile
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-29 15:07:44 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-29 15:07:44 +0100
commitc9ac6938788ee1708e7c900f8f78e9037aea1ca1 (patch)
tree7775fcc8916726b2e7a58d7a251dee69292d231f /dev-python/tifffile
parent23fb10c075a74a6504647a16c3e06a6378e208c8 (diff)
gentoo auto-resync : 29:07:2022 - 15:07:44
Diffstat (limited to 'dev-python/tifffile')
-rw-r--r--dev-python/tifffile/Manifest2
-rw-r--r--dev-python/tifffile/tifffile-2022.7.28.ebuild53
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/tifffile/Manifest b/dev-python/tifffile/Manifest
index 94467726fd82..058b16acabc4 100644
--- a/dev-python/tifffile/Manifest
+++ b/dev-python/tifffile/Manifest
@@ -1,3 +1,5 @@
DIST tifffile-2022.5.4.gh.tar.gz 290116 BLAKE2B 4c608ad38ad7ada0e1b41512eae7b4109680cab1f5623ea3cd6c01dfe17b534b518868ee21879ecfa9909f7680a04fbb63967b5c8064062cc325286baaaccb6b SHA512 cc6139872c42e0e2840a9774989b5cba57ef8957e2efa4349e7b224c61ebb8ad34287b9305dddd85b1239d03be4ada73526259b038c19c73513007e5f63d224d
+DIST tifffile-2022.7.28.gh.tar.gz 309010 BLAKE2B 4a52a688ce7f09265592f8bd2bed2eaf9648304908aa1b190c07a22b58f10bb3f71f9ea1f9a612a2592f75f457acc04cc2139ef0cbd75ea40a7e91408075062b SHA512 12647884cb77fc8e414c09aface82def1ad2bb0a11a1f17fa00e6954cf565a906b6a8c9e861d0a476a86ef8ea25da12d1069199109cb84030d312021d722f23e
EBUILD tifffile-2022.5.4.ebuild 1307 BLAKE2B e8d54bd2167e36d459d27d5d661339fac170426c90b0cc061d01a312b93563af890e0e342ebb287557a57eeb6e64e373243e1b04630ca42f80c16c2eb5cc5906 SHA512 9ba9172bf4621a59a8518ddc5caa6e5f0968a79373f2cd487b4510a98ef6b9f78380707bd4afedca2d0202dbbdc49574101e39dad961fdf2fd0d584e2f265e56
+EBUILD tifffile-2022.7.28.ebuild 1307 BLAKE2B e8d54bd2167e36d459d27d5d661339fac170426c90b0cc061d01a312b93563af890e0e342ebb287557a57eeb6e64e373243e1b04630ca42f80c16c2eb5cc5906 SHA512 9ba9172bf4621a59a8518ddc5caa6e5f0968a79373f2cd487b4510a98ef6b9f78380707bd4afedca2d0202dbbdc49574101e39dad961fdf2fd0d584e2f265e56
MISC metadata.xml 346 BLAKE2B 8cecb51fe01826a2a190c4e3020836f5706a918515a3ef5b4624fc3e9985411a8fd3c261fb7b6d8ad4f4486164487d11bdc2b071eeb5a95083db4c5323ae2dbe SHA512 81f8f6f5231d6cc9a8e7f95416a63cc52027f58fa54ce16bacfaa0ae285a48c5a3850d83d5ab50ca89be248ce386528db32811b23d61fa0d0e1e0cc737150465
diff --git a/dev-python/tifffile/tifffile-2022.7.28.ebuild b/dev-python/tifffile/tifffile-2022.7.28.ebuild
new file mode 100644
index 000000000000..c7b39355f0d6
--- /dev/null
+++ b/dev-python/tifffile/tifffile-2022.7.28.ebuild
@@ -0,0 +1,53 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Read and write TIFF files"
+HOMEPAGE="
+ https://pypi.org/project/tifffile/
+ https://github.com/cgohlke/tifffile/
+ https://www.lfd.uci.edu/~gohlke/
+"
+SRC_URI="
+ https://github.com/cgohlke/tifffile/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/numpy-1.19.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/dask[${PYTHON_USEDEP}]
+ >=dev-python/fsspec-2021.5.0[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/xarray[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Internet
+ tests/test_tifffile.py::test_class_omexml
+ tests/test_tifffile.py::test_class_omexml_fail
+ tests/test_tifffile.py::test_class_omexml_modulo
+ tests/test_tifffile.py::test_class_omexml_attributes
+ tests/test_tifffile.py::test_class_omexml_multiimage
+ tests/test_tifffile.py::test_write_ome
+ tests/test_tifffile.py::test_write_ome_manual
+ # requires tons of free space
+ tests/test_tifffile.py::test_write_3gb
+ tests/test_tifffile.py::test_write_bigtiff
+ 'tests/test_tifffile.py::test_write_imagej_raw'
+)