summaryrefslogtreecommitdiff
path: root/dev-python/tifffile
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /dev-python/tifffile
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'dev-python/tifffile')
-rw-r--r--dev-python/tifffile/Manifest3
-rw-r--r--dev-python/tifffile/metadata.xml11
-rw-r--r--dev-python/tifffile/tifffile-2021.11.2.ebuild54
3 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/tifffile/Manifest b/dev-python/tifffile/Manifest
new file mode 100644
index 000000000000..8b480149ff74
--- /dev/null
+++ b/dev-python/tifffile/Manifest
@@ -0,0 +1,3 @@
+DIST tifffile-2021.11.2.gh.tar.gz 261953 BLAKE2B 039e25b173d2074b5a869394bb40cd62410b34c8a86bf047cd203aad6ab0e3217d0f4006bb092840acb314598c73619e48c66daa04c81f9965ca46b81f055d6e SHA512 5bd3340af027547bf07d78523c5c2abcecb428606d72daa446c7f3cd06f7c8da015e20cd0f4ebeb1e9a49ce0aaf6c2840170dad7a8a28e403716d4bdb1ba2238
+EBUILD tifffile-2021.11.2.ebuild 1392 BLAKE2B 29a491ca8a5b880117ae61cbe143a7e6a6151b25794ac31d5ed0edcb86ad3b68e5060152145a3ea5e93f295c266ee4f3d631844d6c3d88c274ff4a6228d7b968 SHA512 427d69fa2ff5053463759d2cd32912f77e438d4c797f2328a2608b6f4554a1afb0f003aae44f714922f75437b68efbb56349cd117cef21ca85764d94fbea9129
+MISC metadata.xml 346 BLAKE2B 8cecb51fe01826a2a190c4e3020836f5706a918515a3ef5b4624fc3e9985411a8fd3c261fb7b6d8ad4f4486164487d11bdc2b071eeb5a95083db4c5323ae2dbe SHA512 81f8f6f5231d6cc9a8e7f95416a63cc52027f58fa54ce16bacfaa0ae285a48c5a3850d83d5ab50ca89be248ce386528db32811b23d61fa0d0e1e0cc737150465
diff --git a/dev-python/tifffile/metadata.xml b/dev-python/tifffile/metadata.xml
new file mode 100644
index 000000000000..f3fa5ef3f318
--- /dev/null
+++ b/dev-python/tifffile/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">tifffile</remote-id>
+ <remote-id type="github">cgohlke/tifffile</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/tifffile/tifffile-2021.11.2.ebuild b/dev-python/tifffile/tifffile-2021.11.2.ebuild
new file mode 100644
index 000000000000..88ad83347a2a
--- /dev/null
+++ b/dev-python/tifffile/tifffile-2021.11.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Read and write TIFF files"
+HOMEPAGE="
+ https://pypi.org/project/tifffile/
+ https://github.com/cgohlke/tifffile/
+ https://www.lfd.uci.edu/~gohlke/
+"
+SRC_URI="
+ https://github.com/cgohlke/tifffile/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/numpy-1.15.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/dask[${PYTHON_USEDEP}]
+ ' python3_{8..9})
+ >=dev-python/fsspec-2021.5.0[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Internet
+ tests/test_tifffile.py::test_class_omexml
+ tests/test_tifffile.py::test_class_omexml_fail
+ tests/test_tifffile.py::test_class_omexml_modulo
+ tests/test_tifffile.py::test_class_omexml_attributes
+ tests/test_tifffile.py::test_class_omexml_multiimage
+ tests/test_tifffile.py::test_write_ome
+ tests/test_tifffile.py::test_write_ome_manual
+ # requires tons of free space
+ tests/test_tifffile.py::test_write_3gb
+ tests/test_tifffile.py::test_write_bigtiff
+ 'tests/test_tifffile.py::test_write_imagej_raw'
+ # requires files not in tarball (upstream misses this one in skip)
+ tests/test_tifffile.py::test_write_predictor
+)