summaryrefslogtreecommitdiff
path: root/dev-python/tifffile
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-08 11:32:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-08 11:32:01 +0100
commit74cd29ea4467291ea2c34971de87d6bdc21233e9 (patch)
treed7039021b01e3b7bb7d02edc26d71052836b7832 /dev-python/tifffile
parentcb861ca8e611e651d4203590e0a9c3c4c2196bd4 (diff)
gentoo auto-resync : 08:04:2023 - 11:32:01
Diffstat (limited to 'dev-python/tifffile')
-rw-r--r--dev-python/tifffile/Manifest2
-rw-r--r--dev-python/tifffile/tifffile-2023.3.15.ebuild60
2 files changed, 0 insertions, 62 deletions
diff --git a/dev-python/tifffile/Manifest b/dev-python/tifffile/Manifest
index 274b83d62b05..6c2fce4d3081 100644
--- a/dev-python/tifffile/Manifest
+++ b/dev-python/tifffile/Manifest
@@ -1,5 +1,3 @@
-DIST tifffile-2023.3.15.gh.tar.gz 331071 BLAKE2B 4bb1f725bd38523dd60383aab530c8e8ec25a71fc5e9350cc77023ab2ce4bd8c5d85dc97a50144fc0148710be8bd7b0f8b5f20d4e2f9a85b541cc9b0e41ebfaa SHA512 b7f8f5a0a4dbacc409a39b1906104ee0024e7275ca1d7dd4cf3137b29dc38ef13103719ab191f7b61e2ef939e734d7442977d5f3a2c6560a1ce0361cd488ca7c
DIST tifffile-2023.3.21.gh.tar.gz 331285 BLAKE2B ce63dc2f389d3e93cf50c52efe849423c091bdf048ce7f408fe6ee4556da4b9efcbaa031e7bc7f2b3f953117f7ce18014d1a77f9253a82d6dc4352464cf4151d SHA512 68b90d7eab293991b0227090d5b4c047469cd65c339f8d19da68097d99640c7f45cf8746eac4b3da9a388a58cd4343bbcad25496b08c13c913e48f982e14f5b9
-EBUILD tifffile-2023.3.15.ebuild 1600 BLAKE2B 2a75f65bcbe7cfa39d1d9778521c7c201c01e4bdaf5c5d24a47748e2eb6a849e7e1a1f508c1d49453de839bbfa2e0b0eaddbf8910c6d5a0fbb2e5364791a275e SHA512 ea82d23134791f8748abe1fcc0386fe57adb00d5eefe57174b3bbc2bca3c790538c13d78f675e5f1f4559b236a62738bcd613087a9c59893770466db90385dea
EBUILD tifffile-2023.3.21.ebuild 1600 BLAKE2B 2a75f65bcbe7cfa39d1d9778521c7c201c01e4bdaf5c5d24a47748e2eb6a849e7e1a1f508c1d49453de839bbfa2e0b0eaddbf8910c6d5a0fbb2e5364791a275e SHA512 ea82d23134791f8748abe1fcc0386fe57adb00d5eefe57174b3bbc2bca3c790538c13d78f675e5f1f4559b236a62738bcd613087a9c59893770466db90385dea
MISC metadata.xml 346 BLAKE2B 8cecb51fe01826a2a190c4e3020836f5706a918515a3ef5b4624fc3e9985411a8fd3c261fb7b6d8ad4f4486164487d11bdc2b071eeb5a95083db4c5323ae2dbe SHA512 81f8f6f5231d6cc9a8e7f95416a63cc52027f58fa54ce16bacfaa0ae285a48c5a3850d83d5ab50ca89be248ce386528db32811b23d61fa0d0e1e0cc737150465
diff --git a/dev-python/tifffile/tifffile-2023.3.15.ebuild b/dev-python/tifffile/tifffile-2023.3.15.ebuild
deleted file mode 100644
index 66babf481615..000000000000
--- a/dev-python/tifffile/tifffile-2023.3.15.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 2021-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Read and write TIFF files"
-HOMEPAGE="
- https://pypi.org/project/tifffile/
- https://github.com/cgohlke/tifffile/
- https://www.cgohlke.com/
-"
-SRC_URI="
- https://github.com/cgohlke/tifffile/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- >=dev-python/numpy-1.19.2[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/dask[${PYTHON_USEDEP}]
- dev-python/defusedxml[${PYTHON_USEDEP}]
- >=dev-python/fsspec-2021.5.0[${PYTHON_USEDEP}]
- dev-python/lxml[${PYTHON_USEDEP}]
- dev-python/xarray[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- # Internet
- tests/test_tifffile.py::test_class_omexml
- tests/test_tifffile.py::test_class_omexml_fail
- tests/test_tifffile.py::test_class_omexml_modulo
- tests/test_tifffile.py::test_class_omexml_attributes
- tests/test_tifffile.py::test_class_omexml_multiimage
- tests/test_tifffile.py::test_write_ome
- tests/test_tifffile.py::test_write_ome_manual
- # requires tons of free space
- tests/test_tifffile.py::test_write_3gb
- tests/test_tifffile.py::test_write_5GB_bigtiff
- tests/test_tifffile.py::test_write_5GB_fails
- tests/test_tifffile.py::test_write_6gb
- tests/test_tifffile.py::test_write_bigtiff
- 'tests/test_tifffile.py::test_write_imagej_raw'
- # TODO
- tests/test_tifffile.py::test_issue_imagej_hyperstack_arg
- tests/test_tifffile.py::test_issue_description_overwrite
-)