summaryrefslogtreecommitdiff
path: root/dev-python/tifffile
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-30 05:49:55 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-30 05:49:55 +0000
commit73e3b099187df1c4f2df056e45f345a56d2535aa (patch)
tree42fef135111a0d9bb70b2843f3d9158875b891b0 /dev-python/tifffile
parentb0c85b2635958d1aa7c9cee8dbf22ad871a280f1 (diff)
gentoo auto-resync : 30:01:2024 - 05:49:55
Diffstat (limited to 'dev-python/tifffile')
-rw-r--r--dev-python/tifffile/Manifest2
-rw-r--r--dev-python/tifffile/tifffile-2024.1.30.ebuild57
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/tifffile/Manifest b/dev-python/tifffile/Manifest
index e9cd0d20e6e7..5cbc91bff2fe 100644
--- a/dev-python/tifffile/Manifest
+++ b/dev-python/tifffile/Manifest
@@ -1,3 +1,5 @@
DIST tifffile-2023.12.9.gh.tar.gz 343750 BLAKE2B c6f3ae05870bbd3fbf67915b2d88ad6662362c28842412449510df8162dc1eb0fd52adb322c4d163c5c3bbc61c182fde08bc38d7b7a4cf6df5554d8e89e6b6c9 SHA512 de51d75cff08f617d638dbd062940ddcd2b0a0ffb25d4670e8d68bd8bcf19ff299695d7b0c8248d5405bfb0015c539b3dacb5133816eace7d0e93cff4f0d2c00
+DIST tifffile-2024.1.30.gh.tar.gz 344378 BLAKE2B 7030219f88a5d4f6cc974a1a433bc10ad1bdcb395632e8b7034a681ddf4cf3b00fcd17df7ac2f4f9796980a74d140b9450f08f5535257b0a1ac05f17cb3c2031 SHA512 96a346c19ed252f8483c49a954bf84f9603b752d00292266131666e4a06ed4826677d9082eda4086d87eace8f3ce28909832267240d92affb810873b9d0a3fe1
EBUILD tifffile-2023.12.9.ebuild 1687 BLAKE2B 97229b200967748180782b205bef3f175ac5c7156892017d6759045a7ddcb0fc25bfb44bf941ad31909610e261dd93040932cbff94ee6bca4d8901c97fa4a2fe SHA512 9661c8e46ec363c269bc215e4abd812b93cfee24a15823459e8925a4eeea2fa294786cd0d2e08e20a0b55b25160a47c10be67646b6695ea4c906cff670e1363f
+EBUILD tifffile-2024.1.30.ebuild 1483 BLAKE2B 83e6ba6e2de1ae9f2b3fd547158d7c704d297114fdbfb9eabe18367c11229b2067afcb5fbea36d9cb1e4daead28d3bc5100389443184168a1ffe1bc1556b3acd SHA512 45299ed858a744be8f3dc458ff9da321b171b52d12a76da21d94d7aa161c38fb736664279efb5da9228a359c25c7e00c050622ef455588e1351e3408f6912a23
MISC metadata.xml 346 BLAKE2B 8cecb51fe01826a2a190c4e3020836f5706a918515a3ef5b4624fc3e9985411a8fd3c261fb7b6d8ad4f4486164487d11bdc2b071eeb5a95083db4c5323ae2dbe SHA512 81f8f6f5231d6cc9a8e7f95416a63cc52027f58fa54ce16bacfaa0ae285a48c5a3850d83d5ab50ca89be248ce386528db32811b23d61fa0d0e1e0cc737150465
diff --git a/dev-python/tifffile/tifffile-2024.1.30.ebuild b/dev-python/tifffile/tifffile-2024.1.30.ebuild
new file mode 100644
index 000000000000..d58751a45db4
--- /dev/null
+++ b/dev-python/tifffile/tifffile-2024.1.30.ebuild
@@ -0,0 +1,57 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Read and write TIFF files"
+HOMEPAGE="
+ https://pypi.org/project/tifffile/
+ https://github.com/cgohlke/tifffile/
+ https://www.cgohlke.com/
+"
+SRC_URI="
+ https://github.com/cgohlke/tifffile/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/numpy-1.19.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/dask[${PYTHON_USEDEP}]
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ >=dev-python/fsspec-2021.5.0[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/xarray[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Internet
+ tests/test_tifffile.py::test_class_omexml
+ tests/test_tifffile.py::test_class_omexml_fail
+ tests/test_tifffile.py::test_class_omexml_modulo
+ tests/test_tifffile.py::test_class_omexml_attributes
+ tests/test_tifffile.py::test_class_omexml_multiimage
+ tests/test_tifffile.py::test_write_ome
+ tests/test_tifffile.py::test_write_ome_manual
+ # requires tons of free space
+ tests/test_tifffile.py::test_write_3gb
+ tests/test_tifffile.py::test_write_5GB_bigtiff
+ tests/test_tifffile.py::test_write_5GB_fails
+ tests/test_tifffile.py::test_write_6gb
+ tests/test_tifffile.py::test_write_bigtiff
+ 'tests/test_tifffile.py::test_write_imagej_raw'
+)