summaryrefslogtreecommitdiff
path: root/dev-python/tifffile
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-02 07:28:45 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-02 07:28:45 +0000
commit4c91fc4c0d1da2829c584bd0517280eb4daf33d5 (patch)
tree0ae0ff890238f90dcc97bff617271214c48d2f1f /dev-python/tifffile
parent5711c6777e7610093a43849c3d874c52ac421b64 (diff)
gentoo auto-resync : 02:03:2023 - 07:28:45
Diffstat (limited to 'dev-python/tifffile')
-rw-r--r--dev-python/tifffile/Manifest2
-rw-r--r--dev-python/tifffile/tifffile-2023.2.28.ebuild60
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/tifffile/Manifest b/dev-python/tifffile/Manifest
index 4a4a8ec69a46..c7f96cf6c780 100644
--- a/dev-python/tifffile/Manifest
+++ b/dev-python/tifffile/Manifest
@@ -1,5 +1,7 @@
DIST tifffile-2023.2.27.gh.tar.gz 326444 BLAKE2B 8c5081b7434329181d5f6df416b739c43d24ff9a9c3dc2ac4b3d6d6dd5ba165290d224648e5e6b4f46bd611c85204114f8b563cb110b7b50ba73aefd0e427f2e SHA512 97ba6b6ac469e4ab92822fd51dc45ebc00776834e5b171679abed24448d5be479a06e5e401bd055a21029641668f63912246b93f15424a3b268733729515452e
+DIST tifffile-2023.2.28.gh.tar.gz 326769 BLAKE2B e7495832d4fbcfa524a5e1aa4f34663378aa3a7d05743e0a564e008a052b8eb1f9ad5a26fbf89064947957ae6029ab6a51ea8669eb785a188443fffa1947ff98 SHA512 b9e2e58c03937aa839f83ac7b3126fe4d4f0eab4fa6d09dc88380e2f894497ab65d9bb7ca9947170ccd9026531e23e99252db4fb9c61b44c891297c2df197751
DIST tifffile-2023.2.3.gh.tar.gz 324906 BLAKE2B b9417ea561de7a185f1a57a6f36a6efde12caa85cd15fd787ae1ca50e73d328f83ec6cd196042d3a11a62706ac27bfad8ecc42e0a235201ee208fdb95d942c16 SHA512 f73dd77c149afa976ac468f0fac37a1bafe35ae4bcb377a91e7922573237805cdc6e00cbcd7bb78f3213a9da4878ec020a058567523b9a4c5958e013f9bdc94b
EBUILD tifffile-2023.2.27.ebuild 1600 BLAKE2B 2a75f65bcbe7cfa39d1d9778521c7c201c01e4bdaf5c5d24a47748e2eb6a849e7e1a1f508c1d49453de839bbfa2e0b0eaddbf8910c6d5a0fbb2e5364791a275e SHA512 ea82d23134791f8748abe1fcc0386fe57adb00d5eefe57174b3bbc2bca3c790538c13d78f675e5f1f4559b236a62738bcd613087a9c59893770466db90385dea
+EBUILD tifffile-2023.2.28.ebuild 1600 BLAKE2B 2a75f65bcbe7cfa39d1d9778521c7c201c01e4bdaf5c5d24a47748e2eb6a849e7e1a1f508c1d49453de839bbfa2e0b0eaddbf8910c6d5a0fbb2e5364791a275e SHA512 ea82d23134791f8748abe1fcc0386fe57adb00d5eefe57174b3bbc2bca3c790538c13d78f675e5f1f4559b236a62738bcd613087a9c59893770466db90385dea
EBUILD tifffile-2023.2.3.ebuild 1600 BLAKE2B 2a75f65bcbe7cfa39d1d9778521c7c201c01e4bdaf5c5d24a47748e2eb6a849e7e1a1f508c1d49453de839bbfa2e0b0eaddbf8910c6d5a0fbb2e5364791a275e SHA512 ea82d23134791f8748abe1fcc0386fe57adb00d5eefe57174b3bbc2bca3c790538c13d78f675e5f1f4559b236a62738bcd613087a9c59893770466db90385dea
MISC metadata.xml 346 BLAKE2B 8cecb51fe01826a2a190c4e3020836f5706a918515a3ef5b4624fc3e9985411a8fd3c261fb7b6d8ad4f4486164487d11bdc2b071eeb5a95083db4c5323ae2dbe SHA512 81f8f6f5231d6cc9a8e7f95416a63cc52027f58fa54ce16bacfaa0ae285a48c5a3850d83d5ab50ca89be248ce386528db32811b23d61fa0d0e1e0cc737150465
diff --git a/dev-python/tifffile/tifffile-2023.2.28.ebuild b/dev-python/tifffile/tifffile-2023.2.28.ebuild
new file mode 100644
index 000000000000..66babf481615
--- /dev/null
+++ b/dev-python/tifffile/tifffile-2023.2.28.ebuild
@@ -0,0 +1,60 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Read and write TIFF files"
+HOMEPAGE="
+ https://pypi.org/project/tifffile/
+ https://github.com/cgohlke/tifffile/
+ https://www.cgohlke.com/
+"
+SRC_URI="
+ https://github.com/cgohlke/tifffile/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/numpy-1.19.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/dask[${PYTHON_USEDEP}]
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ >=dev-python/fsspec-2021.5.0[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/xarray[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Internet
+ tests/test_tifffile.py::test_class_omexml
+ tests/test_tifffile.py::test_class_omexml_fail
+ tests/test_tifffile.py::test_class_omexml_modulo
+ tests/test_tifffile.py::test_class_omexml_attributes
+ tests/test_tifffile.py::test_class_omexml_multiimage
+ tests/test_tifffile.py::test_write_ome
+ tests/test_tifffile.py::test_write_ome_manual
+ # requires tons of free space
+ tests/test_tifffile.py::test_write_3gb
+ tests/test_tifffile.py::test_write_5GB_bigtiff
+ tests/test_tifffile.py::test_write_5GB_fails
+ tests/test_tifffile.py::test_write_6gb
+ tests/test_tifffile.py::test_write_bigtiff
+ 'tests/test_tifffile.py::test_write_imagej_raw'
+ # TODO
+ tests/test_tifffile.py::test_issue_imagej_hyperstack_arg
+ tests/test_tifffile.py::test_issue_description_overwrite
+)