summaryrefslogtreecommitdiff
path: root/dev-python/tifffile
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-23 12:55:08 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-23 12:55:08 +0000
commit47bb4031ea0e98a9423d423f2181c0e3d06f256b (patch)
tree6a54fb70ac916b8ae725d002ac4a71386c8b6e2f /dev-python/tifffile
parent9a1d1c6b10a4640cea10e7040ed173cf593f4cab (diff)
gentoo auto-resync : 23:01:2023 - 12:55:07
Diffstat (limited to 'dev-python/tifffile')
-rw-r--r--dev-python/tifffile/Manifest2
-rw-r--r--dev-python/tifffile/tifffile-2023.1.23.1.ebuild60
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/tifffile/Manifest b/dev-python/tifffile/Manifest
index cf2583bfa4b8..202c63aec44c 100644
--- a/dev-python/tifffile/Manifest
+++ b/dev-python/tifffile/Manifest
@@ -1,3 +1,5 @@
DIST tifffile-2022.10.10.gh.tar.gz 315965 BLAKE2B 9f1d5c37062fd2fd2c30411b479d77977d387e4df19ae795fba085179f7ad0e3dfafa6068ccc895586f59a2437a1203748b3e1bbeb0f4a2d433728c2e79fc47a SHA512 7ccd6b4b802e63ca2646ea4f716fb16f02a091042c02d200c7a6756dc06a60d7d165aa5fefc63db954e60dcaf6bf8626349de7e4b836394b70df7ee71ec28790
+DIST tifffile-2023.1.23.1.gh.tar.gz 324017 BLAKE2B ffc4a329096ac3eb44990635dea4f5d0211564d5a8847795671d3d816148721d3c6fab059514764eb45bc48c8a114382c0a1705cc606d750ef869d49e67b2c85 SHA512 fad8e2f40cc550a83030b29b528566d7b5b9cbe016c9fd04911ab4cca4e8e69523d9b17db83eee018d1ff3005cab0f36762b4a1271859b504c77a0809e07b0be
EBUILD tifffile-2022.10.10-r1.ebuild 1424 BLAKE2B ce6678d2af8e80d05d39302422d9b8c16be8e719f67de0983461185979091eb7900ccde86fb36eb06e6858ce2771c679ec809a6e4c964906df9bc97c5548ff0f SHA512 d2de577d3ac4a91c2a3797b8e8a8476d743969c2397fbdd7fa36e117d76663d53dd5a08ba2bb7369ec7763583c0d4b89048406539943a916046dc91d0e69eeba
+EBUILD tifffile-2023.1.23.1.ebuild 1600 BLAKE2B 2a75f65bcbe7cfa39d1d9778521c7c201c01e4bdaf5c5d24a47748e2eb6a849e7e1a1f508c1d49453de839bbfa2e0b0eaddbf8910c6d5a0fbb2e5364791a275e SHA512 ea82d23134791f8748abe1fcc0386fe57adb00d5eefe57174b3bbc2bca3c790538c13d78f675e5f1f4559b236a62738bcd613087a9c59893770466db90385dea
MISC metadata.xml 346 BLAKE2B 8cecb51fe01826a2a190c4e3020836f5706a918515a3ef5b4624fc3e9985411a8fd3c261fb7b6d8ad4f4486164487d11bdc2b071eeb5a95083db4c5323ae2dbe SHA512 81f8f6f5231d6cc9a8e7f95416a63cc52027f58fa54ce16bacfaa0ae285a48c5a3850d83d5ab50ca89be248ce386528db32811b23d61fa0d0e1e0cc737150465
diff --git a/dev-python/tifffile/tifffile-2023.1.23.1.ebuild b/dev-python/tifffile/tifffile-2023.1.23.1.ebuild
new file mode 100644
index 000000000000..66babf481615
--- /dev/null
+++ b/dev-python/tifffile/tifffile-2023.1.23.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Read and write TIFF files"
+HOMEPAGE="
+ https://pypi.org/project/tifffile/
+ https://github.com/cgohlke/tifffile/
+ https://www.cgohlke.com/
+"
+SRC_URI="
+ https://github.com/cgohlke/tifffile/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/numpy-1.19.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/dask[${PYTHON_USEDEP}]
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ >=dev-python/fsspec-2021.5.0[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/xarray[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Internet
+ tests/test_tifffile.py::test_class_omexml
+ tests/test_tifffile.py::test_class_omexml_fail
+ tests/test_tifffile.py::test_class_omexml_modulo
+ tests/test_tifffile.py::test_class_omexml_attributes
+ tests/test_tifffile.py::test_class_omexml_multiimage
+ tests/test_tifffile.py::test_write_ome
+ tests/test_tifffile.py::test_write_ome_manual
+ # requires tons of free space
+ tests/test_tifffile.py::test_write_3gb
+ tests/test_tifffile.py::test_write_5GB_bigtiff
+ tests/test_tifffile.py::test_write_5GB_fails
+ tests/test_tifffile.py::test_write_6gb
+ tests/test_tifffile.py::test_write_bigtiff
+ 'tests/test_tifffile.py::test_write_imagej_raw'
+ # TODO
+ tests/test_tifffile.py::test_issue_imagej_hyperstack_arg
+ tests/test_tifffile.py::test_issue_description_overwrite
+)