summaryrefslogtreecommitdiff
path: root/dev-python/tifffile
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-18 12:04:39 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-18 12:04:39 +0100
commit2d01b3d133c0fbf17de8d7b47905585af88bd6e4 (patch)
treef74eb9a3d16ed25f8c15b825f4d28b759ae99a42 /dev-python/tifffile
parent97bacba3ead078e5db8b87ab651a3ffa7d82f60f (diff)
gentoo auto-resync : 18:04:2024 - 12:04:39
Diffstat (limited to 'dev-python/tifffile')
-rw-r--r--dev-python/tifffile/Manifest2
-rw-r--r--dev-python/tifffile/tifffile-2024.4.18.ebuild57
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/tifffile/Manifest b/dev-python/tifffile/Manifest
index feb408e2b3b6..9064ab162e55 100644
--- a/dev-python/tifffile/Manifest
+++ b/dev-python/tifffile/Manifest
@@ -1,3 +1,5 @@
DIST tifffile-2024.2.12.gh.tar.gz 344964 BLAKE2B 13b1697258daa6643f87d7d8a44f638789b3182029ac1d97b1695ac9add3bee4f295d1485b35273a031ce17b0c41b5fdb12d43f03765d96960869bb82c78adb8 SHA512 0cb1f33b879047b311d4ba7b8a00164230935bbd1403f33d3a1a44bedf1797e5f4b066fae865ae990da5356c0a868e4a5722f1da36ff77d8cd9b550d58286552
+DIST tifffile-2024.4.18.gh.tar.gz 346262 BLAKE2B d281e14a4bf9f29c81973a3b6bb52205b2657945b41592862a07f306957a5aa3bd8cab40db8ed5872f8544fc293deb247dbc765e94ef2d70bfefa4b5592f4d6d SHA512 bcd7f23979595d1c74a0aabe94429d6952e3a86d135b78eda0219254664a557cab13efad05ce52b9d9b60b96d8f088af7e5cfd0f07f001da5488ad6758a421bf
EBUILD tifffile-2024.2.12.ebuild 1483 BLAKE2B 83e6ba6e2de1ae9f2b3fd547158d7c704d297114fdbfb9eabe18367c11229b2067afcb5fbea36d9cb1e4daead28d3bc5100389443184168a1ffe1bc1556b3acd SHA512 45299ed858a744be8f3dc458ff9da321b171b52d12a76da21d94d7aa161c38fb736664279efb5da9228a359c25c7e00c050622ef455588e1351e3408f6912a23
+EBUILD tifffile-2024.4.18.ebuild 1483 BLAKE2B 83e6ba6e2de1ae9f2b3fd547158d7c704d297114fdbfb9eabe18367c11229b2067afcb5fbea36d9cb1e4daead28d3bc5100389443184168a1ffe1bc1556b3acd SHA512 45299ed858a744be8f3dc458ff9da321b171b52d12a76da21d94d7aa161c38fb736664279efb5da9228a359c25c7e00c050622ef455588e1351e3408f6912a23
MISC metadata.xml 346 BLAKE2B 8cecb51fe01826a2a190c4e3020836f5706a918515a3ef5b4624fc3e9985411a8fd3c261fb7b6d8ad4f4486164487d11bdc2b071eeb5a95083db4c5323ae2dbe SHA512 81f8f6f5231d6cc9a8e7f95416a63cc52027f58fa54ce16bacfaa0ae285a48c5a3850d83d5ab50ca89be248ce386528db32811b23d61fa0d0e1e0cc737150465
diff --git a/dev-python/tifffile/tifffile-2024.4.18.ebuild b/dev-python/tifffile/tifffile-2024.4.18.ebuild
new file mode 100644
index 000000000000..d58751a45db4
--- /dev/null
+++ b/dev-python/tifffile/tifffile-2024.4.18.ebuild
@@ -0,0 +1,57 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Read and write TIFF files"
+HOMEPAGE="
+ https://pypi.org/project/tifffile/
+ https://github.com/cgohlke/tifffile/
+ https://www.cgohlke.com/
+"
+SRC_URI="
+ https://github.com/cgohlke/tifffile/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/numpy-1.19.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/dask[${PYTHON_USEDEP}]
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ >=dev-python/fsspec-2021.5.0[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/xarray[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Internet
+ tests/test_tifffile.py::test_class_omexml
+ tests/test_tifffile.py::test_class_omexml_fail
+ tests/test_tifffile.py::test_class_omexml_modulo
+ tests/test_tifffile.py::test_class_omexml_attributes
+ tests/test_tifffile.py::test_class_omexml_multiimage
+ tests/test_tifffile.py::test_write_ome
+ tests/test_tifffile.py::test_write_ome_manual
+ # requires tons of free space
+ tests/test_tifffile.py::test_write_3gb
+ tests/test_tifffile.py::test_write_5GB_bigtiff
+ tests/test_tifffile.py::test_write_5GB_fails
+ tests/test_tifffile.py::test_write_6gb
+ tests/test_tifffile.py::test_write_bigtiff
+ 'tests/test_tifffile.py::test_write_imagej_raw'
+)