summaryrefslogtreecommitdiff
path: root/dev-python/tifffile
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-07-04 08:06:08 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-07-04 08:06:08 +0100
commit2a8d2f71d1d9963368e0ef3d641d75979a689d12 (patch)
tree83e283f960ab2ebbc1a042b8ed6c37b78d47b37b /dev-python/tifffile
parent8435c842b9e8fbb2bcc80397ab3aa655000459e2 (diff)
gentoo auto-resync : 04:07:2024 - 08:06:07
Diffstat (limited to 'dev-python/tifffile')
-rw-r--r--dev-python/tifffile/Manifest2
-rw-r--r--dev-python/tifffile/tifffile-2024.7.2.ebuild47
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/tifffile/Manifest b/dev-python/tifffile/Manifest
index 4cc23936c341..ba4f3d89007e 100644
--- a/dev-python/tifffile/Manifest
+++ b/dev-python/tifffile/Manifest
@@ -1,3 +1,5 @@
DIST tifffile-2024.6.18.gh.tar.gz 349752 BLAKE2B 35f11d963e93e6b1f6b5e4a026dd0f1aed1bf03a2a5e9caab7649ce95c00cdd99988aaa864c549555a8244ec8bfc8d8d900386aa7b9f853fd5aca7b8bece8eb4 SHA512 fdbb5b2b335743f0aef01d5a8f0b577eb24fb1b89d29e20c1971124bdb58f61aab4e3471b6f91e686010c8ca1d5786527357b123c2d801c16d423927315b8c94
+DIST tifffile-2024.7.2.gh.tar.gz 349770 BLAKE2B c722f23857310826568f54bffa4f071c8018c6d17ee810dad423f6e9ad80ee99f888bf9282e8cc53d710ba5052c69136e8385aa7ac7e9052346fa766cfdc1747 SHA512 11efbda0f20428fbff4863f52425021de9303be8ad76051c7daf5921f1282a88655872c98dcb2530ea354b1f2833509b3b98b82d035dc8bbae4a4d2da0ef8d47
EBUILD tifffile-2024.6.18.ebuild 912 BLAKE2B 72f813492d481934acb63f72ede3145181f2e9267485b8fae567929a1e94e1a288599076851f8c67083687d282e8d16bbd90786c970d5b26e5c2e2843436229f SHA512 877932d4597684f7cfa0e2524b1192f14207febdfeb3a545253bb98c5c9d44c453161ea7d837c565ac5530d434fccbe842b70ddf4454ca60a9b2ad190523a7c6
+EBUILD tifffile-2024.7.2.ebuild 912 BLAKE2B 72f813492d481934acb63f72ede3145181f2e9267485b8fae567929a1e94e1a288599076851f8c67083687d282e8d16bbd90786c970d5b26e5c2e2843436229f SHA512 877932d4597684f7cfa0e2524b1192f14207febdfeb3a545253bb98c5c9d44c453161ea7d837c565ac5530d434fccbe842b70ddf4454ca60a9b2ad190523a7c6
MISC metadata.xml 346 BLAKE2B 8cecb51fe01826a2a190c4e3020836f5706a918515a3ef5b4624fc3e9985411a8fd3c261fb7b6d8ad4f4486164487d11bdc2b071eeb5a95083db4c5323ae2dbe SHA512 81f8f6f5231d6cc9a8e7f95416a63cc52027f58fa54ce16bacfaa0ae285a48c5a3850d83d5ab50ca89be248ce386528db32811b23d61fa0d0e1e0cc737150465
diff --git a/dev-python/tifffile/tifffile-2024.7.2.ebuild b/dev-python/tifffile/tifffile-2024.7.2.ebuild
new file mode 100644
index 000000000000..190a5b9ccada
--- /dev/null
+++ b/dev-python/tifffile/tifffile-2024.7.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Read and write TIFF files"
+HOMEPAGE="
+ https://pypi.org/project/tifffile/
+ https://github.com/cgohlke/tifffile/
+ https://www.cgohlke.com/
+"
+SRC_URI="
+ https://github.com/cgohlke/tifffile/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/numpy-1.19.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ >=dev-python/fsspec-2021.5.0[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/xarray[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_test() {
+ local -x SKIP_LARGE=1
+ local -x SKIP_HTTP=1
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}