summaryrefslogtreecommitdiff
path: root/dev-python/tifffile/tifffile-2022.8.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-09 20:16:39 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-09 20:16:39 +0100
commit69202c9dc2e21292adc03d8e2083e15f1814f321 (patch)
tree82c271263914afa1a5d15340b63461197e407532 /dev-python/tifffile/tifffile-2022.8.8.ebuild
parentc62f31f933c259fc576a912eed0856ca03346fc4 (diff)
gentoo auto-resync : 09:08:2022 - 20:16:39
Diffstat (limited to 'dev-python/tifffile/tifffile-2022.8.8.ebuild')
-rw-r--r--dev-python/tifffile/tifffile-2022.8.8.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/tifffile/tifffile-2022.8.8.ebuild b/dev-python/tifffile/tifffile-2022.8.8.ebuild
new file mode 100644
index 000000000000..867f25de5f9d
--- /dev/null
+++ b/dev-python/tifffile/tifffile-2022.8.8.ebuild
@@ -0,0 +1,53 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Read and write TIFF files"
+HOMEPAGE="
+ https://pypi.org/project/tifffile/
+ https://github.com/cgohlke/tifffile/
+ https://www.cgohlke.com/
+"
+SRC_URI="
+ https://github.com/cgohlke/tifffile/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/numpy-1.19.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/dask[${PYTHON_USEDEP}]
+ >=dev-python/fsspec-2021.5.0[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/xarray[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Internet
+ tests/test_tifffile.py::test_class_omexml
+ tests/test_tifffile.py::test_class_omexml_fail
+ tests/test_tifffile.py::test_class_omexml_modulo
+ tests/test_tifffile.py::test_class_omexml_attributes
+ tests/test_tifffile.py::test_class_omexml_multiimage
+ tests/test_tifffile.py::test_write_ome
+ tests/test_tifffile.py::test_write_ome_manual
+ # requires tons of free space
+ tests/test_tifffile.py::test_write_3gb
+ tests/test_tifffile.py::test_write_bigtiff
+ 'tests/test_tifffile.py::test_write_imagej_raw'
+)