summaryrefslogtreecommitdiff
path: root/dev-python/thunarx-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/thunarx-python
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/thunarx-python')
-rw-r--r--dev-python/thunarx-python/Manifest5
-rw-r--r--dev-python/thunarx-python/metadata.xml12
-rw-r--r--dev-python/thunarx-python/thunarx-python-0.3.0-r2.ebuild34
-rw-r--r--dev-python/thunarx-python/thunarx-python-0.5.1.ebuild31
4 files changed, 82 insertions, 0 deletions
diff --git a/dev-python/thunarx-python/Manifest b/dev-python/thunarx-python/Manifest
new file mode 100644
index 000000000000..3bd6d9e1f8ed
--- /dev/null
+++ b/dev-python/thunarx-python/Manifest
@@ -0,0 +1,5 @@
+DIST thunarx-python-0.3.0.tar.bz2 303035 BLAKE2B af0193a3bc97c859ba98f52c612d5af81c5b7a0d8142a8283cf2b308fa183ac57ac1a2163cd882749b6fd33e0529f20f1f9e2db2dcc1aed26cb40cd5995780fb SHA512 9be3e8b50cd668e0b63fbf54da5dec3685dde40528067b35bd1cfa87db7e037962baafce3059818a7de76101472a2b07ae209c590f2f143dbc71646e8addb28f
+DIST thunarx-python-0.5.1.tar.bz2 334426 BLAKE2B 59f8e625b10ceeaefffa4b6dde150c32023365e76854c6e77ae2f222b509856353c8d62de26ba4e7b967cfcce1219205923938389fd1714a420bc9e1ac2b12b2 SHA512 0c1d8f20b74a3eb87b3c2c181c6438bc059dff75afdc26cfea19dffb7efe1f14e6a880689f73afcbbcb5922312741df72018e3b9980c4a45426e7a7d4651177f
+EBUILD thunarx-python-0.3.0-r2.ebuild 778 BLAKE2B 57afb8f9b5469211715bee3139ad5c07d665e42331a940014695376a2b881b3e2d3e94b81af7e38ecaec8504bac59c34201b2ce8c2ba938b35af24cad9fef536 SHA512 7313f7552e7cbcf31fc83305d81e65452651e77f17d7d57b5d9a4dbe917c8dbe3343a2f02f7d76f2ff1f2475dd46b2fc3bd7ad41c6173adaf6b98387bd957e1f
+EBUILD thunarx-python-0.5.1.ebuild 736 BLAKE2B 18ca72da40bd039c860ae5f94ed63dec66b6e98c73011a0467a7e335e2ee22fccd34e982e1fb3885eda5cf66225949a8003399d609a358f850aa463be6cbccb1 SHA512 21153a227919970d8d44d87fccd3ed07ef93eeb7c4843e55d7b1d9769eeea189c30820d57030931b8d635915414c294c4d2cd59730b0a9ee50c86c78f9778449
+MISC metadata.xml 357 BLAKE2B 48cf41f710ba774f8adaea9825d2b72803e19e55a76afea97cec934449c0723d7ca411ee20297652179abd621bd6bbf533aaed3ebe0d6601b13ad26840d225c9 SHA512 f707818cf1217c314e8c0a18c990f4b1e65b358e7fefe68490d59956c97aa40a2f2b0130d89a54a658dc2caea11e0c5a01f04553faab53dd32513bc299e90b58
diff --git a/dev-python/thunarx-python/metadata.xml b/dev-python/thunarx-python/metadata.xml
new file mode 100644
index 000000000000..7bdac6c6ba25
--- /dev/null
+++ b/dev-python/thunarx-python/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>xfce@gentoo.org</email>
+ <name>XFCE Team</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>xmw@gentoo.org</email>
+ <name>Michael Weber</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/thunarx-python/thunarx-python-0.3.0-r2.ebuild b/dev-python/thunarx-python/thunarx-python-0.3.0-r2.ebuild
new file mode 100644
index 000000000000..8d348aeb4c1a
--- /dev/null
+++ b/dev-python/thunarx-python/thunarx-python-0.3.0-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1
+
+DESCRIPTION="Python bindings for the Thunar file manager"
+HOMEPAGE="https://goodies.xfce.org/projects/bindings/thunarx-python"
+SRC_URI="https://archive.xfce.org/src/bindings/${PN}/0.3/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="${PYTHON_DEPS}
+ x11-libs/gtk+:2
+ dev-libs/glib:2
+ >=dev-python/pygobject-2.16:2[${PYTHON_USEDEP}]
+ dev-python/pygtk:2[${PYTHON_USEDEP}]
+ <xfce-base/thunar-1.7"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+}
diff --git a/dev-python/thunarx-python/thunarx-python-0.5.1.ebuild b/dev-python/thunarx-python/thunarx-python-0.5.1.ebuild
new file mode 100644
index 000000000000..ffe9dde4ac34
--- /dev/null
+++ b/dev-python/thunarx-python/thunarx-python-0.5.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+
+inherit python-single-r1
+
+DESCRIPTION="Python bindings for the Thunar file manager"
+HOMEPAGE="https://goodies.xfce.org/projects/bindings/thunarx-python"
+SRC_URI="https://archive.xfce.org/src/bindings/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="${PYTHON_DEPS}
+ >=x11-libs/gtk+-3.20:3
+ >=dev-libs/glib-2.30:2
+ >=dev-python/pygobject-3.20:3[${PYTHON_USEDEP}]
+ >=xfce-base/thunar-1.7.0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+}