summaryrefslogtreecommitdiff
path: root/dev-python/thriftpy2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-09 09:25:48 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-09 09:25:48 +0000
commitfc2c8b325a27d1dd0e181a50517601b4fde8aa7f (patch)
treeef1849fa20636bdbda9fa704f3bfba6ee73bd418 /dev-python/thriftpy2
parent7db983f17e59dfa621d994bcbdbddc71a6e70a57 (diff)
gentoo auto-resync : 09:11:2022 - 09:25:48
Diffstat (limited to 'dev-python/thriftpy2')
-rw-r--r--dev-python/thriftpy2/Manifest2
-rw-r--r--dev-python/thriftpy2/thriftpy2-0.4.15.ebuild59
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/thriftpy2/Manifest b/dev-python/thriftpy2/Manifest
index 0968c25de5bf..b999e8d4c565 100644
--- a/dev-python/thriftpy2/Manifest
+++ b/dev-python/thriftpy2/Manifest
@@ -1,3 +1,5 @@
DIST thriftpy2-0.4.14.gh.tar.gz 127552 BLAKE2B 4061642fb14b60ba53e0c4e6342ead25f781ee923b718a6c557235fcbfe4219b4d8944894afe9783062e7950b689b909af6be5cefe3b634a476ec582adfefbed SHA512 0b248c4999b0a97287d8db3e5b79ac687bc7e25a5478ef125b479e0baf9be9d0aa5f9eaadf0612c228133295743ba913bfe69e7fe59a8d5f854a682da9d31c50
+DIST thriftpy2-0.4.15.gh.tar.gz 136581 BLAKE2B 68287057e76ec6f2b91d9fca9a63e1814e2e17f4fb074b5f227b177137452f88921adf4912c66fee206b29d9f32cd0eb43cbbbe275574c21babc12b1f949672e SHA512 c5a17e42ac8a4051714938a4db926a25f41c84e4935fcf18c62ef8b115d9a1df3853800ca6c9fa01cafd6cbdfe31b6b4eabc7a81169a4773e0bda2241c4a26fb
EBUILD thriftpy2-0.4.14-r1.ebuild 938 BLAKE2B e227e4c8c80ecb497fc990788a394a916ae88526f14ce1201408cbc796f77fa7551575bc0b4ef627f0a5884b8f3b9243e601f406d5427946c519155f7bc4e359 SHA512 b254759b808ef1600035829d4e6c10bc5328fd482c363716b0718781c92e1769b5080c6d957d1827c1e2e078a327a3ce19610adcfe4ef9a395653f2d5dafc0c7
+EBUILD thriftpy2-0.4.15.ebuild 1392 BLAKE2B 4ecc4bc5f8ca79ed9d08a93c7dc47a4c951d88d6292ca74c5ad2d2cae3186407f83fcee562fbbe022900675f19bd1e60277b9d264a88decb4de4b4b956f47183 SHA512 681682afa1a3d8bc73f98e3caee2f4cd121adf0d776d33e964a74649bb46dbdc304e2dc619339db4c27626b84b43f88e4e919d05557f989e198568cdbe067e6e
MISC metadata.xml 380 BLAKE2B 570746c7985eab098e590e49d267c406ce02cbf612dda6bf2a60439aee62cbf6eefebac14af29bf5fa52c8b5fd4846b2872beb7034364abb722f706978b55987 SHA512 d20d8641eea699cfa6d1930b8c5a9a8edfe76b5ef837551c52105d2fe8d70d481862c5d5cdbe389971588b3bdf62e9fb7e1cec2e89d635650cbabed7f7f53070
diff --git a/dev-python/thriftpy2/thriftpy2-0.4.15.ebuild b/dev-python/thriftpy2/thriftpy2-0.4.15.ebuild
new file mode 100644
index 000000000000..f9d60e1c27f2
--- /dev/null
+++ b/dev-python/thriftpy2/thriftpy2-0.4.15.ebuild
@@ -0,0 +1,59 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure python approach of Apache Thrift"
+HOMEPAGE="
+ https://github.com/Thriftpy/thriftpy2/
+ https://pypi.org/project/thriftpy2/
+"
+SRC_URI="
+ https://github.com/Thriftpy/thriftpy2/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/ply[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/tornado[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # broken by modern OpenSSL defaults
+ tests/test_rpc.py::test_clients
+ tests/test_rpc.py::test_void_api_with_ssl
+ tests/test_rpc.py::test_string_api_with_ssl
+ tests/test_rpc.py::test_huge_res_with_ssl
+ tests/test_rpc.py::test_tstruct_req_with_ssl
+ tests/test_rpc.py::test_tstruct_res_with_ssl
+ tests/test_rpc.py::test_complex_tstruct_with_ssl
+ tests/test_rpc.py::test_exception_iwth_ssl
+ tests/test_sslsocket.py
+
+ # TODO
+ tests/test_tornado.py::TornadoRPCTestCase::test_asynchronous_exception
+ tests/test_tornado.py::TornadoRPCTestCase::test_asynchronous_result
+ )
+
+ cd tests || die
+ epytest
+}