summaryrefslogtreecommitdiff
path: root/dev-python/thriftpy2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-28 02:49:59 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-28 02:49:59 +0000
commite53aa6b4fbe5a0c6db75d893829f7a6a37a14180 (patch)
treedd095d36490410a724fd271fcdf08c31a5336edd /dev-python/thriftpy2
parentc5ee568457ac776b65b71fa444e0dd47535bc44a (diff)
gentoo auto-resync : 28:01:2023 - 02:49:59
Diffstat (limited to 'dev-python/thriftpy2')
-rw-r--r--dev-python/thriftpy2/Manifest2
-rw-r--r--dev-python/thriftpy2/thriftpy2-0.4.15.ebuild59
2 files changed, 0 insertions, 61 deletions
diff --git a/dev-python/thriftpy2/Manifest b/dev-python/thriftpy2/Manifest
index 045387252257..d4130177463b 100644
--- a/dev-python/thriftpy2/Manifest
+++ b/dev-python/thriftpy2/Manifest
@@ -1,5 +1,3 @@
-DIST thriftpy2-0.4.15.gh.tar.gz 136581 BLAKE2B 68287057e76ec6f2b91d9fca9a63e1814e2e17f4fb074b5f227b177137452f88921adf4912c66fee206b29d9f32cd0eb43cbbbe275574c21babc12b1f949672e SHA512 c5a17e42ac8a4051714938a4db926a25f41c84e4935fcf18c62ef8b115d9a1df3853800ca6c9fa01cafd6cbdfe31b6b4eabc7a81169a4773e0bda2241c4a26fb
DIST thriftpy2-0.4.16.gh.tar.gz 146991 BLAKE2B 7547ea85106d0929d3e6ee771ff10ad2cd047f4e779c668e4a30ee936ac04d470e16d8321a2771db4404f57e1be41438b4a302bc04b8e4698db03de35dbfa5e9 SHA512 c00b21eb7db3fe91843a5129d16e7af2a29331489e7d8394bcf78eb5c4b8054162b9c5a024eec8080708dbffc491db7922258ecd895477cda49dcc7d56297ecf
-EBUILD thriftpy2-0.4.15.ebuild 1392 BLAKE2B e4eaef0717c2ce1b4720940b2b215f557794bc1ce0593b68d4b0688b8f5226bd9bf146a7e6bd244b06d73ad68a607f23a985603013747f431c7d29ad3edfca20 SHA512 247ca7245bcfbff468347b19bff4cd632a174df2cec9214f8fe24011047f9db22320ea2891ae8f5a372600c77c1726634faeb8d670e40aa809cf54938329a957
EBUILD thriftpy2-0.4.16.ebuild 960 BLAKE2B 04af3c1c136f01968f1dd83779b71b383e93119e3d4a0ab8212bca6936bf2dc62730f43c189a6d0715f01fc6f7a3c2a815f5b8c2ba21c5686341291d33219910 SHA512 66448f2850a0971985cb13deadb5476b8c9cf7aa753c2dbe2ba786fb8bdce52674ffc21c9ede502a9389e2cecbd375f210ace504234aec03ab0bff718f58b250
MISC metadata.xml 380 BLAKE2B 570746c7985eab098e590e49d267c406ce02cbf612dda6bf2a60439aee62cbf6eefebac14af29bf5fa52c8b5fd4846b2872beb7034364abb722f706978b55987 SHA512 d20d8641eea699cfa6d1930b8c5a9a8edfe76b5ef837551c52105d2fe8d70d481862c5d5cdbe389971588b3bdf62e9fb7e1cec2e89d635650cbabed7f7f53070
diff --git a/dev-python/thriftpy2/thriftpy2-0.4.15.ebuild b/dev-python/thriftpy2/thriftpy2-0.4.15.ebuild
deleted file mode 100644
index a1563308e4b7..000000000000
--- a/dev-python/thriftpy2/thriftpy2-0.4.15.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 2021-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Pure python approach of Apache Thrift"
-HOMEPAGE="
- https://github.com/Thriftpy/thriftpy2/
- https://pypi.org/project/thriftpy2/
-"
-SRC_URI="
- https://github.com/Thriftpy/thriftpy2/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- dev-python/ply[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/cython[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- dev-python/tornado[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # broken by modern OpenSSL defaults
- tests/test_rpc.py::test_clients
- tests/test_rpc.py::test_void_api_with_ssl
- tests/test_rpc.py::test_string_api_with_ssl
- tests/test_rpc.py::test_huge_res_with_ssl
- tests/test_rpc.py::test_tstruct_req_with_ssl
- tests/test_rpc.py::test_tstruct_res_with_ssl
- tests/test_rpc.py::test_complex_tstruct_with_ssl
- tests/test_rpc.py::test_exception_iwth_ssl
- tests/test_sslsocket.py
-
- # TODO
- tests/test_tornado.py::TornadoRPCTestCase::test_asynchronous_exception
- tests/test_tornado.py::TornadoRPCTestCase::test_asynchronous_result
- )
-
- cd tests || die
- epytest
-}