summaryrefslogtreecommitdiff
path: root/dev-python/thriftpy2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-14 06:50:14 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-14 06:50:14 +0000
commitafa8da78d8135ca28150730e9c60af9d875f0a5b (patch)
tree65e94479f29d7591a1bc1d09d1fc1913d785fe6b /dev-python/thriftpy2
parent4828c25c25aacf399de429d381288982fd7e0d0e (diff)
gentoo auto-resync : 14:11:2022 - 06:50:13
Diffstat (limited to 'dev-python/thriftpy2')
-rw-r--r--dev-python/thriftpy2/Manifest2
-rw-r--r--dev-python/thriftpy2/thriftpy2-0.4.14-r1.ebuild40
2 files changed, 0 insertions, 42 deletions
diff --git a/dev-python/thriftpy2/Manifest b/dev-python/thriftpy2/Manifest
index b999e8d4c565..d5e80e4b3b4b 100644
--- a/dev-python/thriftpy2/Manifest
+++ b/dev-python/thriftpy2/Manifest
@@ -1,5 +1,3 @@
-DIST thriftpy2-0.4.14.gh.tar.gz 127552 BLAKE2B 4061642fb14b60ba53e0c4e6342ead25f781ee923b718a6c557235fcbfe4219b4d8944894afe9783062e7950b689b909af6be5cefe3b634a476ec582adfefbed SHA512 0b248c4999b0a97287d8db3e5b79ac687bc7e25a5478ef125b479e0baf9be9d0aa5f9eaadf0612c228133295743ba913bfe69e7fe59a8d5f854a682da9d31c50
DIST thriftpy2-0.4.15.gh.tar.gz 136581 BLAKE2B 68287057e76ec6f2b91d9fca9a63e1814e2e17f4fb074b5f227b177137452f88921adf4912c66fee206b29d9f32cd0eb43cbbbe275574c21babc12b1f949672e SHA512 c5a17e42ac8a4051714938a4db926a25f41c84e4935fcf18c62ef8b115d9a1df3853800ca6c9fa01cafd6cbdfe31b6b4eabc7a81169a4773e0bda2241c4a26fb
-EBUILD thriftpy2-0.4.14-r1.ebuild 938 BLAKE2B e227e4c8c80ecb497fc990788a394a916ae88526f14ce1201408cbc796f77fa7551575bc0b4ef627f0a5884b8f3b9243e601f406d5427946c519155f7bc4e359 SHA512 b254759b808ef1600035829d4e6c10bc5328fd482c363716b0718781c92e1769b5080c6d957d1827c1e2e078a327a3ce19610adcfe4ef9a395653f2d5dafc0c7
EBUILD thriftpy2-0.4.15.ebuild 1392 BLAKE2B 4ecc4bc5f8ca79ed9d08a93c7dc47a4c951d88d6292ca74c5ad2d2cae3186407f83fcee562fbbe022900675f19bd1e60277b9d264a88decb4de4b4b956f47183 SHA512 681682afa1a3d8bc73f98e3caee2f4cd121adf0d776d33e964a74649bb46dbdc304e2dc619339db4c27626b84b43f88e4e919d05557f989e198568cdbe067e6e
MISC metadata.xml 380 BLAKE2B 570746c7985eab098e590e49d267c406ce02cbf612dda6bf2a60439aee62cbf6eefebac14af29bf5fa52c8b5fd4846b2872beb7034364abb722f706978b55987 SHA512 d20d8641eea699cfa6d1930b8c5a9a8edfe76b5ef837551c52105d2fe8d70d481862c5d5cdbe389971588b3bdf62e9fb7e1cec2e89d635650cbabed7f7f53070
diff --git a/dev-python/thriftpy2/thriftpy2-0.4.14-r1.ebuild b/dev-python/thriftpy2/thriftpy2-0.4.14-r1.ebuild
deleted file mode 100644
index 635c852ae836..000000000000
--- a/dev-python/thriftpy2/thriftpy2-0.4.14-r1.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 2021-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="Pure python approach of Apache Thrift"
-HOMEPAGE="https://github.com/Thriftpy/thriftpy2"
-SRC_URI="https://github.com/Thriftpy/thriftpy2/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-BDEPEND="
- dev-python/cython[${PYTHON_USEDEP}]
- dev-python/ply[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- dev-python/tornado[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests --install pytest
-
-python_prepare_all() {
- # tests that need network access
- rm tests/test_{tornado,rpc,sslsocket}.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- distutils_install_for_testing --via-root
- pushd tests >/dev/null || die
- epytest
- popd >/dev/null || die
-}