summaryrefslogtreecommitdiff
path: root/dev-python/thriftpy2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-28 05:40:38 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-28 05:40:38 +0000
commit88f366f99d8e731ae1a13d9eca9a5284484d2c6f (patch)
tree07a82726de0e87969c85cdfb68522c4d444939e9 /dev-python/thriftpy2
parentfdd31f37b982d2c1b6d73b85f99718b13031be36 (diff)
gentoo auto-resync : 28:02:2024 - 05:40:38
Diffstat (limited to 'dev-python/thriftpy2')
-rw-r--r--dev-python/thriftpy2/Manifest2
-rw-r--r--dev-python/thriftpy2/thriftpy2-0.4.19.ebuild44
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/thriftpy2/Manifest b/dev-python/thriftpy2/Manifest
index 0395658626a2..f0e9fa2c7a0c 100644
--- a/dev-python/thriftpy2/Manifest
+++ b/dev-python/thriftpy2/Manifest
@@ -1,3 +1,5 @@
DIST thriftpy2-0.4.17.tar.gz 519386 BLAKE2B 29c383cb886debb7167fbcef3526d0c027dc60db5ae20c554ea19067bb9a3ab40bea50392bd903293c5d9de1e3bc210220d887bd71194f91345a7565f577ccd9 SHA512 7c58eb6d0c91c933e31654d28ce2f4ef04854551db3eb5b8022565932761c74d95f27d44fc847f93723e535fdb4997fdad66a9dba432aa44e27e069e73b7ff7e
+DIST thriftpy2-0.4.19.tar.gz 689034 BLAKE2B 556d47b65b0f9801627515ab7e3fc9907af50b43e8197142626e51b8110ffd740285c895e9ee98e6e0bd8074b9e2f4e9811ce309a68d006dc504f80b3ca38ae6 SHA512 a67160e742683ecd4e47007cd4a6a52f78ab3ae492aa4c170f725d25f1a78fb6a0054cab691752b20a43ff855df61207d302af65ae5966ee5c3f961ff1e42650
EBUILD thriftpy2-0.4.17.ebuild 889 BLAKE2B fc0ac876a82cc52d88e98bf58b93fbd4e1bf20c2fe6e8d7821679ad399bb81ad1312ae23279774a566f16c0be18bfed050944e9ef582a74fce1b22830187ce0b SHA512 9c36508262e6ebb52bcd0db9129be9b6a20550ff9ade7cb1e040f39fa27225c0762d4b32aed5a71d78ce1ce6e291a4e2d5d5eb1ec70ba10c32d32366cc26c17f
+EBUILD thriftpy2-0.4.19.ebuild 889 BLAKE2B b726492be322828913a73ed4692c8375ca421d766545e8b31de4110df2a51ae5daa490bb52141ecd96f9e63825edf5e6f28b332ab64f8e3aa5231fabb97880f0 SHA512 94edff8858fc78010787405fba14d752b7349679c4ea46d0f6b5eba01b2d8ec7bff694543c3a5035000a1df0bf3d4468686fcf70589574aed86e319f5ff20b15
MISC metadata.xml 380 BLAKE2B 570746c7985eab098e590e49d267c406ce02cbf612dda6bf2a60439aee62cbf6eefebac14af29bf5fa52c8b5fd4846b2872beb7034364abb722f706978b55987 SHA512 d20d8641eea699cfa6d1930b8c5a9a8edfe76b5ef837551c52105d2fe8d70d481862c5d5cdbe389971588b3bdf62e9fb7e1cec2e89d635650cbabed7f7f53070
diff --git a/dev-python/thriftpy2/thriftpy2-0.4.19.ebuild b/dev-python/thriftpy2/thriftpy2-0.4.19.ebuild
new file mode 100644
index 000000000000..7fb9eb1ee949
--- /dev/null
+++ b/dev-python/thriftpy2/thriftpy2-0.4.19.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Pure python approach of Apache Thrift"
+HOMEPAGE="
+ https://github.com/Thriftpy/thriftpy2/
+ https://pypi.org/project/thriftpy2/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/ply[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/tornado[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ tests/test_tornado.py::TornadoRPCTestCase::test_asynchronous_exception
+ tests/test_tornado.py::TornadoRPCTestCase::test_asynchronous_result
+ )
+
+ cd tests || die
+ epytest
+}