summaryrefslogtreecommitdiff
path: root/dev-python/thriftpy2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-03 22:39:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-03 22:39:47 +0100
commit7f0ccc917c7abe6223784c703d86cd14755691fb (patch)
tree8c6793f68896b341e22f33d7e6cef88e481f4a8b /dev-python/thriftpy2
parent9aa80713372911cec499b3adb2cd746790920916 (diff)
gentoo resync : 03.07.2021
Diffstat (limited to 'dev-python/thriftpy2')
-rw-r--r--dev-python/thriftpy2/Manifest3
-rw-r--r--dev-python/thriftpy2/metadata.xml8
-rw-r--r--dev-python/thriftpy2/thriftpy2-0.4.14.ebuild39
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/thriftpy2/Manifest b/dev-python/thriftpy2/Manifest
new file mode 100644
index 000000000000..db1ad9ab5e94
--- /dev/null
+++ b/dev-python/thriftpy2/Manifest
@@ -0,0 +1,3 @@
+DIST thriftpy2-0.4.14.tar.gz 127552 BLAKE2B 4061642fb14b60ba53e0c4e6342ead25f781ee923b718a6c557235fcbfe4219b4d8944894afe9783062e7950b689b909af6be5cefe3b634a476ec582adfefbed SHA512 0b248c4999b0a97287d8db3e5b79ac687bc7e25a5478ef125b479e0baf9be9d0aa5f9eaadf0612c228133295743ba913bfe69e7fe59a8d5f854a682da9d31c50
+EBUILD thriftpy2-0.4.14.ebuild 880 BLAKE2B 8b711aa1c10aeedc3e4998f9fb50a3ebbbefa96513b4f7283b75854b961566e51e291847541accf91fd9aff58b0640a7fcff656968c44af8f73191a111fe5e22 SHA512 cb62288b5b9ca13d4bf0739effe56e5dab8c1a727b3a4955ae081e8a0a3e4d6430e6dad8872bb2ab1044e5393287cee345d0e52d17005149da8bc24e857291ff
+MISC metadata.xml 249 BLAKE2B 9e4529cdac0a55f14c36fde3fa54e30645a61a73d58e83ce460edf84d729bb3cd4cdc3e52d588690945508bc7d253b1edfb7734ebee94a88b75fee249a043c84 SHA512 ecad16da7f98e9b1cb1882147e6d8b7d541e4839d92fc26f3db1bea69ed633637da9259947b2b78d204a11d0edd3daa84f173613b6dc19110b5406c6fddfa7f0
diff --git a/dev-python/thriftpy2/metadata.xml b/dev-python/thriftpy2/metadata.xml
new file mode 100644
index 000000000000..cee379b15409
--- /dev/null
+++ b/dev-python/thriftpy2/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chutzpah@gentoo.org</email>
+ <name>Patrick McLean</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/thriftpy2/thriftpy2-0.4.14.ebuild b/dev-python/thriftpy2/thriftpy2-0.4.14.ebuild
new file mode 100644
index 000000000000..16727441076a
--- /dev/null
+++ b/dev-python/thriftpy2/thriftpy2-0.4.14.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="Pure python approach of Apache Thrift"
+HOMEPAGE="https://github.com/Thriftpy/thriftpy2"
+SRC_URI="https://github.com/Thriftpy/thriftpy2/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/ply[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ www-servers/tornado[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests --install pytest
+
+python_prepare_all() {
+ rm tests/test_tornado.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ distutils_install_for_testing --via-root
+ pushd tests >/dev/null || die
+ epytest
+ popd >/dev/null || die
+}