summaryrefslogtreecommitdiff
path: root/dev-python/thrift
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /dev-python/thrift
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'dev-python/thrift')
-rw-r--r--dev-python/thrift/Manifest2
-rw-r--r--dev-python/thrift/thrift-0.14.1.ebuild27
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/thrift/Manifest b/dev-python/thrift/Manifest
index 9f47030f93f5..5dbf76a319aa 100644
--- a/dev-python/thrift/Manifest
+++ b/dev-python/thrift/Manifest
@@ -1,3 +1,5 @@
DIST thrift-0.13.0.tar.gz 59911 BLAKE2B b45363c2e8bbc5c7fae25533c7df9be49e6ea88b5ce077e9a580c28decf06de608d50100ba77cdb1ce8c7e56b87608d193b8579a4f89cc4fb74d672da0ba7e93 SHA512 063440db324efdae1fc4466133deaedeb1edd2f953f6924191ad819476f7b62a434d52960837e94516a673063ceab8b446b4f7dc8c94bb2d1fb84e95d2fa3d78
+DIST thrift-0.14.1.tar.gz 4311458 BLAKE2B 00c0b77c3d722b0db833f03848df0b74ee64712ed1ff06e0b63b926eb493f43ffd9c316422b6044f74685471cdbd2ccea7c6305fd8dbbc10614f2151a3e16237 SHA512 e09e53b2ea3cad01ef81ab4b5a87bfed443cfda849a13c4f00ba0ed1cd1a1f9742faf95adb07f279506cc5f866c13fdce57149de1bc9e71ab5c40238037e8b22
EBUILD thrift-0.13.0.ebuild 546 BLAKE2B 2898ceb825c8fb13fc6c612f4fd24ec62546db75f01f388d50d34cd02ff2d6a2724f72623b661969fed51842a45865cf5b1c9540d3872525e0ebef0ac0293c0d SHA512 15edda06b7739bb7ab957405974adc9f16ac27c78297862538fa89482202b2246c3aa7942e76deb3049cd656f9b84de17859088ca0484ae1369f3132d02718fd
+EBUILD thrift-0.14.1.ebuild 588 BLAKE2B b5d3e6245d4c9ea4b3b5e46c5e8d7aea1be9d9510212ac9d3b358bd06f79a5d603614b94e980adace877aeeef7dd144786ddb6703b80af79553f7c06a1ed4930 SHA512 e9a6fa59158c34f440983662d0850cb03df737ec9051fa3667c24a263c294e6e767b7b9746e667ac8d8809dd8c77dffe83f2fb17b1de2cac8c2d099c6dfdf364
MISC metadata.xml 327 BLAKE2B 68fffa25c9e88a87a56110743553819ef0591f40567594c2ec966e86228bd3a0b0ef0d84f9f002c427b90d1f139d51f1af9786a4451457a7edb43adbcba10ecd SHA512 5f1f04b5bf6a52319bf4810089b26ba4ea4e4ecb0fb44b70322cca98bac1ed2851535fa8d8e6eea38e45c0a411261c5ca966b13a68cd9f3f51c4f7ff003b7291
diff --git a/dev-python/thrift/thrift-0.14.1.ebuild b/dev-python/thrift/thrift-0.14.1.ebuild
new file mode 100644
index 000000000000..bc78792f8bff
--- /dev/null
+++ b/dev-python/thrift/thrift-0.14.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of Thrift"
+HOMEPAGE="https://pypi.org/project/thrift/ https://thrift.apache.org/"
+SRC_URI="https://downloads.apache.org/${PN}/${PV}//${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/${P}/lib/py"
+
+python_install() {
+ distutils-r1_python_install
+ python_optimize
+}