summaryrefslogtreecommitdiff
path: root/dev-python/thrift
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/thrift
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/thrift')
-rw-r--r--dev-python/thrift/Manifest2
-rw-r--r--dev-python/thrift/thrift-0.16.0.ebuild18
2 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/thrift/Manifest b/dev-python/thrift/Manifest
index 513cbdd5b357..ee8f5f9ab643 100644
--- a/dev-python/thrift/Manifest
+++ b/dev-python/thrift/Manifest
@@ -1,3 +1,5 @@
DIST thrift-0.14.1.tar.gz 4311458 BLAKE2B 00c0b77c3d722b0db833f03848df0b74ee64712ed1ff06e0b63b926eb493f43ffd9c316422b6044f74685471cdbd2ccea7c6305fd8dbbc10614f2151a3e16237 SHA512 e09e53b2ea3cad01ef81ab4b5a87bfed443cfda849a13c4f00ba0ed1cd1a1f9742faf95adb07f279506cc5f866c13fdce57149de1bc9e71ab5c40238037e8b22
+DIST thrift-0.16.0.tar.gz 4085114 BLAKE2B 17c35096f6848fb0795e4cb125fed3068c8e1e53f67f404f4dcab67df7a42fc049a7d615591c861eb9e59e3333e21f185e8615663008bc7c846a03722ea8b834 SHA512 468fff6be2def85959fdf8adac92a0cfa7f786083b3bafb2c31427dfe5725f4d10962052d13ea960828f6a317778d35e66b602744a570212352bfc637ae586e0
EBUILD thrift-0.14.1.ebuild 593 BLAKE2B da6f8d820e0f6936906f9f4f13a2072737f2ae9c6c77de2464ca2b8b5e8d62563e6b4abda6600af78fd6d5d8ce06a8dbebcff887054383726382f0bd9b6e0d7b SHA512 1f2511a7ac57737254df5c12a528687b4f62f3ddb78c00888d4e7a2123f1df86e5872587076b2743f29d749c71148f59a5c3f37fe33b5264ec3ef28149af7eff
+EBUILD thrift-0.16.0.ebuild 509 BLAKE2B dd695922a315b078f764ee05b77db4f414dd428c413e9d9dec5b5cdef275ff54b0d3f5b35e11560022b7f311441f597b99a0f4e0265fa94a442c53a5a4f496d8 SHA512 8a6099105bd1053947ae87f7535e92d62ce2728f3d2d1b4b228ec7678aa944548c1206d08699498136c64f10fab9aafd85eb3ccda6098d96a475ea70bad35184
MISC metadata.xml 328 BLAKE2B 945425132ceb24c1286fff7b9b64eb814e331e9df732251040f444efed2740e06e76d44dce88c338d7ffec243f4ef0f2c5ce661cfada5f027a50c79624d35fbc SHA512 271fa461589f5a148fcd06c76a6d9a7dd1469ab090536e858bfc9f43a5039d5836bd2fa77da2dba947d7d85ed6ed30d7ab36bc2df36c5a321bd29389495f90fe
diff --git a/dev-python/thrift/thrift-0.16.0.ebuild b/dev-python/thrift/thrift-0.16.0.ebuild
new file mode 100644
index 000000000000..7e8f3240e62a
--- /dev/null
+++ b/dev-python/thrift/thrift-0.16.0.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of Thrift"
+HOMEPAGE="https://pypi.org/project/thrift/ https://thrift.apache.org/"
+SRC_URI="https://downloads.apache.org/${PN}/${PV}/${P}.tar.gz"
+S="${WORKDIR}/${P}/lib/py"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+RESTRICT="test"