summaryrefslogtreecommitdiff
path: root/dev-python/threadpoolctl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /dev-python/threadpoolctl
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'dev-python/threadpoolctl')
-rw-r--r--dev-python/threadpoolctl/Manifest3
-rw-r--r--dev-python/threadpoolctl/metadata.xml11
-rw-r--r--dev-python/threadpoolctl/threadpoolctl-2.0.0.ebuild23
3 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/threadpoolctl/Manifest b/dev-python/threadpoolctl/Manifest
new file mode 100644
index 000000000000..aa3d8e48c2ea
--- /dev/null
+++ b/dev-python/threadpoolctl/Manifest
@@ -0,0 +1,3 @@
+DIST threadpoolctl-2.0.0.tar.gz 23349 BLAKE2B d7752d862f8de5d61a95dd2e0db9a9cf5b3fde4c13cad9f654c0af4e2277b8bcc36b79028fbdf0e14af35daacee4b01a8778462364e070eaa194af65f4274739 SHA512 8ce823a6aef9f6d6af73e848c7a3bb1c7eee3f94bf480ca056ed5f435655756b9ad26cb71e392689cd8e6a34ee1ddfcf0d8510e424ac9c05bb1eda679d0f7a93
+EBUILD threadpoolctl-2.0.0.ebuild 608 BLAKE2B c7c60bb178d0123863020b0dd69b299faa6b50b0bd556b4da11579282e28c53596eacc28bbbbe94377ccb69ad70a547f1f8c3d640c7d91805fb0c6ac89ff4d1d SHA512 7ef2cd4ae9450e0d80443b7e1855d7540915339e955a7141b493981449c09777502e69b981779290658b207cffbbb33996b0f3bbd4271fc22b2804eb8467c6fd
+MISC metadata.xml 338 BLAKE2B e8be381e5e42a081be3637b77a9b5356dd7d74d0352976badfca62bdf7b65c04554552703b3e12e169ec1c4b57d07cedcf75387a0fd65a8177213f0de8bffa9c SHA512 b3e03151085bcaa51e2108d7e69042523148aaba924415421323d53005c1d047103827ed99bf064cda4f02cc313b3ff4e5fc681bccb5f1f23a82b40a744ed9bc
diff --git a/dev-python/threadpoolctl/metadata.xml b/dev-python/threadpoolctl/metadata.xml
new file mode 100644
index 000000000000..2541628cf9a8
--- /dev/null
+++ b/dev-python/threadpoolctl/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <maintainer type="person">
+ <email>chutzpah@gentoo.org</email>
+ <name>Patrick McLean</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/threadpoolctl/threadpoolctl-2.0.0.ebuild b/dev-python/threadpoolctl/threadpoolctl-2.0.0.ebuild
new file mode 100644
index 000000000000..ae4251fa5508
--- /dev/null
+++ b/dev-python/threadpoolctl/threadpoolctl-2.0.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+inherit distutils-r1
+
+DESCRIPTION="Limit the number of threads used in native libs that have their own threadpool"
+HOMEPAGE="https://github.com/joblib/threadpoolctl"
+SRC_URI="https://github.com/joblib/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="dev-python/cython[${PYTHON_USEDEP}]"
+
+# tests require openmp python bindings...
+RESTRICT=test
+
+distutils_enable_tests pytest