summaryrefslogtreecommitdiff
path: root/dev-python/threadpoolctl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-01 00:00:05 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-01 00:00:05 +0100
commit3d12b65aa1b4bb8b02b1f8d3e77bccf230b79a09 (patch)
treecb6347688c91bfbdebe49a78a55dad3d72cc193e /dev-python/threadpoolctl
parent4c2b70adc6484c35ff05e412de08a7b7f50cfb34 (diff)
gentoo auto-resync : 01:05:2024 - 00:00:04
Diffstat (limited to 'dev-python/threadpoolctl')
-rw-r--r--dev-python/threadpoolctl/Manifest2
-rw-r--r--dev-python/threadpoolctl/threadpoolctl-3.5.0.ebuild41
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/threadpoolctl/Manifest b/dev-python/threadpoolctl/Manifest
index 4336a5f6f91f..8bd644534627 100644
--- a/dev-python/threadpoolctl/Manifest
+++ b/dev-python/threadpoolctl/Manifest
@@ -1,3 +1,5 @@
DIST threadpoolctl-3.4.0.gh.tar.gz 36777 BLAKE2B f5ac09cb2d15ee7c46ebedde61b2ad4e583f4a787bcce8189901f97a56ec030f67fa5dcb20e675b541710db3a48b1983162aa1109b6648a99bb50068590107ac SHA512 3ee49d9936811dd373d25e036e9165aedd1e4d740f0e6a30c5f114c6d58d33321e279919093f1d076c6510fd92dd77273c6d24bf7f6e06030194512093fcc266
+DIST threadpoolctl-3.5.0.gh.tar.gz 37417 BLAKE2B 56b175afb96ce824286f42d0384c158823460b15f66c56b9b904c99e258629ed892906a16f15c3626908c293d25879cc0ca114d0578b1daff3610c2e9b38a3ed SHA512 6b24a6b3df3104b4222df5a20a8c7e321753dfa9ab0df872345a715d5f9ced2a577fe0d730dc4fd382e0ecfdb91a244eb28ba0b831d5db5af98f246f8f56228d
EBUILD threadpoolctl-3.4.0.ebuild 1177 BLAKE2B 3052bcfc25ef59da92cd045d4ed395d46a195df2e2ff59760d5ffc9f7b547c0cff3b85668682c6dbe869635216580a9d64d5924927c4d86dc5388de7c0f189c7 SHA512 cd2f26cd1d302db4b76558f76f7f0a4cb5a985cfe6bde5aae1f0616de2a3a75557c6eaedd225220a034f73bb9c9d82ef0fe31142635d5a92a1a48817d485c8b7
+EBUILD threadpoolctl-3.5.0.ebuild 1181 BLAKE2B cb19362d837d4e38024c5aa996e0a110e36869138f973bade4c7f1b348f650bb893c1a88178c878e9f067c85fa2b9e84508486690a93ce8bd1b9da9a18131a2f SHA512 fff40f09d60f2c00f1f698ad52ade114c78af08595201012822c0243a9937ac93eb87b0050d6e5d9e48923446b32f49dfbd9842d45de20316d311a6b0fd29132
MISC metadata.xml 489 BLAKE2B eba7a68832688f4c6cca1f30e188bae378c82347d87d7a0186fe3821dd04b75fdda2a7826785c3a59eda7362d1119d183be239b06c90ce14096e5a87459d2a29 SHA512 e14a5317dcfb8506a277d358ec227d276cf148e0293fc56b14751804a89fa20134b5be752fcc8beaffd12e246722d34120449a8f1ea0900e2918e42889c54dd8
diff --git a/dev-python/threadpoolctl/threadpoolctl-3.5.0.ebuild b/dev-python/threadpoolctl/threadpoolctl-3.5.0.ebuild
new file mode 100644
index 000000000000..88092a680ad2
--- /dev/null
+++ b/dev-python/threadpoolctl/threadpoolctl-3.5.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Limit the number of threads used in native libs that have their own threadpool"
+HOMEPAGE="
+ https://github.com/joblib/threadpoolctl/
+ https://pypi.org/project/threadpoolctl/
+"
+SRC_URI="
+ https://github.com/joblib/threadpoolctl/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86 ~arm64-macos ~x64-macos"
+
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Asserts against a hardcoded list of CPUs. Either we skip it
+ # or file bugs about missing architectures until upstream realizes
+ # how bad idea that were.
+ tests/test_threadpoolctl.py::test_architecture
+ # This test fails if the Python executable (or any library that it
+ # links to) uses OpenMP. This can particularly be the case with
+ # CPython 3.12 that links to app-crypt/libb2.
+ # https://github.com/joblib/threadpoolctl/issues/146
+ tests/test_threadpoolctl.py::test_command_line_empty
+)