summaryrefslogtreecommitdiff
path: root/dev-python/threadpoolctl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-17 16:03:04 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-17 16:03:04 +0100
commit29ef84a753ab20dbbb228238713a3c7443c6520e (patch)
treeebe889f9f8817c5c6601a6dbfd0b12d537b4e91d /dev-python/threadpoolctl
parentcf89ca044e37f79e2329552cda857215f9824e11 (diff)
gentoo auto-resync : 17:10:2023 - 16:03:04
Diffstat (limited to 'dev-python/threadpoolctl')
-rw-r--r--dev-python/threadpoolctl/Manifest2
-rw-r--r--dev-python/threadpoolctl/threadpoolctl-3.2.0.ebuild7
2 files changed, 7 insertions, 2 deletions
diff --git a/dev-python/threadpoolctl/Manifest b/dev-python/threadpoolctl/Manifest
index 5d9efd3a80b9..88e4683f0e36 100644
--- a/dev-python/threadpoolctl/Manifest
+++ b/dev-python/threadpoolctl/Manifest
@@ -1,3 +1,3 @@
DIST threadpoolctl-3.2.0.gh.tar.gz 32196 BLAKE2B 662b2ab6908719c11881dbaba00437b049f71dc8b6c5c8f4c3733cd156312a6410eca19d0446e11cfaddd039261adb25398a3827e822584ad52b428e67fc6b17 SHA512 01017047ceaa353239fea5410be3b6cd924068d7e18a80bc04cc07f08341e3405fa8620a8e5f43f16b674a3ce535d15e42b41741f78079fb61e618c8b9d1583d
-EBUILD threadpoolctl-3.2.0.ebuild 881 BLAKE2B e0c40d45666f4d98e0daab0136d3fc964802a8a79818140aca1c8339f2269a4dfa2a255dd5a275abe288534ab655fc26c481fbb3fa6fe9bdc86afa38a55a9852 SHA512 87154a3aee2d13eb6d46b601b41f8a004324850b5fd19767a3853f1a7440418aa119adcd22024aeca9589fe7fe0f09348c3d0ff2e91ffb6ab27e3db7b1f40182
+EBUILD threadpoolctl-3.2.0.ebuild 1170 BLAKE2B 31801379266f43030f18ac28bfddcf608b8c6e065137c6c30e0d016efd7be30165a32d42fad6b1900775919cd2bc224ecab66b49dae3fda0695323d0b78df9b4 SHA512 896cc0e4a490f9c38f0693343b42dd76000b0e0b55b6e86dbe3d8a109401294775fcbb79021e3b5ac7c528d70abcebc71973106a12af981dce23f7f52835de5b
MISC metadata.xml 489 BLAKE2B eba7a68832688f4c6cca1f30e188bae378c82347d87d7a0186fe3821dd04b75fdda2a7826785c3a59eda7362d1119d183be239b06c90ce14096e5a87459d2a29 SHA512 e14a5317dcfb8506a277d358ec227d276cf148e0293fc56b14751804a89fa20134b5be752fcc8beaffd12e246722d34120449a8f1ea0900e2918e42889c54dd8
diff --git a/dev-python/threadpoolctl/threadpoolctl-3.2.0.ebuild b/dev-python/threadpoolctl/threadpoolctl-3.2.0.ebuild
index 1c38a89e93ac..654f001a4b38 100644
--- a/dev-python/threadpoolctl/threadpoolctl-3.2.0.ebuild
+++ b/dev-python/threadpoolctl/threadpoolctl-3.2.0.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=flit
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1
@@ -33,4 +33,9 @@ EPYTEST_DESELECT=(
# or file bugs about missing architectures until upstream realizes
# how bad idea that were.
tests/test_threadpoolctl.py::test_architecture
+ # This test fails if the Python executable (or any library that it
+ # links to) uses OpenMP. This can particularly be the case with
+ # CPython 3.12 that links to app-crypt/libb2.
+ # https://github.com/joblib/threadpoolctl/issues/146
+ tests/test_threadpoolctl.py::test_command_line_empty
)