summaryrefslogtreecommitdiff
path: root/dev-python/theano
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-05 09:25:57 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-05 09:25:57 +0000
commit6d691ad5b6239929063441bbd14c489e92e7396e (patch)
treee294f87b1ce66397fee1273bd6c7131aeb586f51 /dev-python/theano
parentd99093fb4bb5652015c06274d64083daa2439e4f (diff)
gentoo resync : 05.03.2021
Diffstat (limited to 'dev-python/theano')
-rw-r--r--dev-python/theano/Manifest2
-rw-r--r--dev-python/theano/theano-1.0.5-r1.ebuild (renamed from dev-python/theano/theano-1.0.5.ebuild)8
2 files changed, 8 insertions, 2 deletions
diff --git a/dev-python/theano/Manifest b/dev-python/theano/Manifest
index 8d61a5637efd..632205320b67 100644
--- a/dev-python/theano/Manifest
+++ b/dev-python/theano/Manifest
@@ -1,3 +1,3 @@
DIST Theano-1.0.5.tar.gz 2842778 BLAKE2B ee82e9487a5265a1040750ace70465c450134e70eba4e58752cbaa7d487be5fb3cce31b838429cb52f7bc31d32a20379e158ee289dd5732dd8b86a9ee36b6d89 SHA512 6bb27753957d32392ea793e39ea56eff94baafbb55e27488f9c0bbdb387172a6829e64f461f83dae192486d9764b72d815e3b8dc059b2af116b024fc7228a118
-EBUILD theano-1.0.5.ebuild 1223 BLAKE2B 94b92d3dd3643826d92f2a2fd3fbc6e087f144b90364058ab5421759ff92cd7d0a9e594961d8128f2450a7dc7696da51baf7ac401c7b3039156da9c115dae95f SHA512 ed255e2c7e05b3c9a7cf16862d95cc544baf60727389827ea29dbe2f4730ff1fcb9f90cb313783ef877a603380d0df33953261bbf5528cff1684fc0f15dd8ea7
+EBUILD theano-1.0.5-r1.ebuild 1424 BLAKE2B e2e21991f6392c7286a96ef8bad8bf91a7e0d98db7d90d9aada7d1f7162dfed300880b74fe4cc8120e1949f4f5b50ac598af86e7473ece51a8d748825b22ee3e SHA512 14ef7961ed800f5dde58f0d8d37c59b0bdbb4e008d38cdb43e6533c733bc8e1a17067b330ef63d70c8a27cadc712bc03145015472785d5f7ec4403c23da63020
MISC metadata.xml 632 BLAKE2B 2bee1d4912596b45d3f5cc0528a927078a072091148dfce38892319b91a0635859fa91dea32565b4a7f5ed02726364a50870bab22197c57ff33c88a48ad9d223 SHA512 653fc6d180455ee24967e70f78682ed2a7e61022d6867390b4c4eb994699b3f293bafe45b4fcf1c4ace3f102acba41c5491e8fb39b9f6102f1022a2c51955ef7
diff --git a/dev-python/theano/theano-1.0.5.ebuild b/dev-python/theano/theano-1.0.5-r1.ebuild
index bf10d34c41e1..aa340176494e 100644
--- a/dev-python/theano/theano-1.0.5.ebuild
+++ b/dev-python/theano/theano-1.0.5-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -42,6 +42,12 @@ python_test() {
nosetests --verbosity=3 -e test_format_flake8 || die
}
+# https://dev.gentoo.org/~mgorny/python-guide/concept.html#packaging-pkgutil-style-namespaces-in-gentoo
+python_install() {
+ rm "${BUILD_DIR}"/lib/bin/__init__.py || die
+ distutils-r1_python_install
+}
+
pkg_postinst() {
optfeature "Make picture of Theano computation graph" dev-python/pydot-ng
optfeature "Required for GPU/CPU code generation" dev-python/pygpu