summaryrefslogtreecommitdiff
path: root/dev-python/textx/textx-1.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/textx/textx-1.4.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/textx/textx-1.4.ebuild')
-rw-r--r--dev-python/textx/textx-1.4.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/textx/textx-1.4.ebuild b/dev-python/textx/textx-1.4.ebuild
new file mode 100644
index 000000000000..bdb75ef49484
--- /dev/null
+++ b/dev-python/textx/textx-1.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+MY_PN=textX
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Meta-language for DSL implementation inspired by Xtext"
+HOMEPAGE="https://pypi.python.org/pypi/${MY_PN} https://github.com/igordejanovic/${MY_PN}"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+# pypi tarball omits tests
+RESTRICT="test"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/arpeggio[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+S=${WORKDIR}/${MY_P}
+
+python_test() {
+ py.test -v tests/functional || die "tests failed"
+}