summaryrefslogtreecommitdiff
path: root/dev-python/texttable/texttable-1.6.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-23 13:08:35 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-23 13:08:35 +0000
commit87cdf8e64e5874146493d2a4a4489b08583043c3 (patch)
treeb481dca3db38189f893c7e9fdf3fb98731b097a9 /dev-python/texttable/texttable-1.6.7.ebuild
parentbed152ba1fc2f1316eaefb5c3d24d48195560f76 (diff)
gentoo auto-resync : 23:11:2022 - 13:08:35
Diffstat (limited to 'dev-python/texttable/texttable-1.6.7.ebuild')
-rw-r--r--dev-python/texttable/texttable-1.6.7.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/texttable/texttable-1.6.7.ebuild b/dev-python/texttable/texttable-1.6.7.ebuild
new file mode 100644
index 000000000000..a67b50ccc120
--- /dev/null
+++ b/dev-python/texttable/texttable-1.6.7.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Module to create simple ASCII tables"
+HOMEPAGE="
+ https://github.com/foutaise/texttable/
+ https://pypi.org/project/texttable/
+"
+SRC_URI="
+ https://github.com/foutaise/texttable/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest tests.py
+}
+
+pkg_postinst() {
+ optfeature "better wrapping of CJK text" dev-python/cjkwrap
+}