summaryrefslogtreecommitdiff
path: root/dev-python/texttable/texttable-1.6.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /dev-python/texttable/texttable-1.6.3.ebuild
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'dev-python/texttable/texttable-1.6.3.ebuild')
-rw-r--r--dev-python/texttable/texttable-1.6.3.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/texttable/texttable-1.6.3.ebuild b/dev-python/texttable/texttable-1.6.3.ebuild
new file mode 100644
index 000000000000..16349f82863d
--- /dev/null
+++ b/dev-python/texttable/texttable-1.6.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Module for creating simple ASCII tables"
+HOMEPAGE="https://github.com/foutaise/texttable https://pypi.org/project/texttable/"
+SRC_URI="https://github.com/foutaise/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="dev-python/wcwidth[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_test() {
+ pytest -vv tests.py || die
+}
+
+pkg_postinst() {
+ elog "Optional features: "
+ optfeature "better wrapping of CJK text" dev-python/cjkwrap
+}