summaryrefslogtreecommitdiff
path: root/dev-python/textfsm
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/textfsm
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/textfsm')
-rw-r--r--dev-python/textfsm/Manifest3
-rw-r--r--dev-python/textfsm/metadata.xml12
-rw-r--r--dev-python/textfsm/textfsm-0.4.0.ebuild25
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/textfsm/Manifest b/dev-python/textfsm/Manifest
new file mode 100644
index 000000000000..7967747a1bd8
--- /dev/null
+++ b/dev-python/textfsm/Manifest
@@ -0,0 +1,3 @@
+DIST textfsm-0.4.0.tar.gz 38355 BLAKE2B ae59973585ab0e1eed04ec300139165cf0634c154056f73697057928d2e17f25c7934171ab20825c6fdfb35f09b18cc0438443b28af356ae6be7a28f4cb8a5af SHA512 fe7d49c48b6e74859180b911a72e8c21bcf263b0403e8fdf28f9790633fb5b48ee2465eb3208c6649e489cb5fda3c4751e1748483042c934285636d190b01998
+EBUILD textfsm-0.4.0.ebuild 713 BLAKE2B ad672995aa3aea8968873233555b98a1a87979d9b450ad6749ccb0d659135cd43410f9c70e8207f8dcd2fcc9be81d4dfa9b6b1650a2bfb6c4d9b16778489abe0 SHA512 3181895175ba67755bb5ef38b97a3956d5f0cf88fcf4466f2f8a8c1a2285cd948bfd6e7f927e9a8dbee58b886545b0ab8a2f3fdc48f4ef963fbc472ca16c0e05
+MISC metadata.xml 381 BLAKE2B f7309078a84a9991b14e84ddf4ae26809e80a67d5995dfe3ec4c5eb261099345bfb53749eec5803dfb2502e9fda9e664622dc9e33ef1b266d7d7d554d3269f0a SHA512 03a1d5979ad678c1975b45b05a3d4f22d9a560416761781aadb0f9747ebb707392f61ad17c4863752587944aca373c9d137c2b226b1172fd97eef6c7079fd907
diff --git a/dev-python/textfsm/metadata.xml b/dev-python/textfsm/metadata.xml
new file mode 100644
index 000000000000..8d38cd9663b8
--- /dev/null
+++ b/dev-python/textfsm/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chainsaw@gentoo.org</email>
+ <name>Tony Vroon</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">google/textfsm</remote-id>
+ <remote-id type="pypi">textfsm</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/textfsm/textfsm-0.4.0.ebuild b/dev-python/textfsm/textfsm-0.4.0.ebuild
new file mode 100644
index 000000000000..68f74eebb2d5
--- /dev/null
+++ b/dev-python/textfsm/textfsm-0.4.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module for parsing semi-structured text into python tables."
+HOMEPAGE="https://github.com/google/textfsm/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="examples"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}