summaryrefslogtreecommitdiff
path: root/dev-python/textdistance
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-29 19:40:20 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-29 19:40:20 +0000
commitd5f4fe0e51ffa8d74055615bc4f0e2e950b5dadb (patch)
tree8d58e1b21ff1398be16b308cf04b4c503b879843 /dev-python/textdistance
parent5cb89cb9de4cdd1a06010c3d45748c33afab2408 (diff)
gentoo auto-resync : 29:12:2023 - 19:40:20
Diffstat (limited to 'dev-python/textdistance')
-rw-r--r--dev-python/textdistance/Manifest2
-rw-r--r--dev-python/textdistance/textdistance-4.6.1.ebuild36
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/textdistance/Manifest b/dev-python/textdistance/Manifest
index afd79d9d7f6c..b46cfe6d1627 100644
--- a/dev-python/textdistance/Manifest
+++ b/dev-python/textdistance/Manifest
@@ -1,3 +1,5 @@
DIST textdistance-4.6.0.gh.tar.gz 46639 BLAKE2B 3d39dfb43c9d3a10ec0c638dd02fd8ee6ccf3d3b06821b8af9331ccfd76a6cae4b33095bd6f71edb670e35a786478f0f7f72baefe4ec3db1a8581a0d8dead4ab SHA512 3e75fde1fc2b0d1dc3917d3860483c5a0aa25affd68c0f05c4888f2404e7e96e6da7b2e581ee3d96626a0a7d4c7ca1e096626224756ec784e72be22681b56116
+DIST textdistance-4.6.1.gh.tar.gz 46618 BLAKE2B 168737e2380380570e67e873913823851e6e50a52f5180d4c5519a71f7899074aff2514f0df1a5d920c1c6a8313522fda6eb987862008eda9221ea8cc5be2902 SHA512 a27256c8ad9a228711acb6d54c5ea05634c89537686751c50623411238ee0b519cf0415e345c83b5cd347bda855751562c37ad88f06c1eacfea959cf2798b97c
EBUILD textdistance-4.6.0.ebuild 691 BLAKE2B 48bb54e9957bc96fc8ab730c7acee4da7739d286dbf173830d3a0faed3423f9acbc3ca1c31b74efc638e258004f3a7e86709723665b3a5355eb8effd49dd95d2 SHA512 fa7e35011ecf2c29680a922b0300425514b7bd5e31b5289a914e8dbf3eb6c06706ff2d4bf321c55d36c108bb568b716d88105ec8c3dbfa2baf92308e5693b62f
+EBUILD textdistance-4.6.1.ebuild 694 BLAKE2B a5e5059d3a110c8ff1fbae76a8af14c4473768e79c15abd736f7b472d49f76f3c617f034629304729df2756047da04f2320b504a4d32f04123cd31b34149cd76 SHA512 62dc54e64d611ca9414bafe8b8339a57db455620a91ed94c164e06ddf08c1df6cb242cd1afc971f28a1a6c8747add3db716616c47497bf87a1008ea4cee3e0a2
MISC metadata.xml 517 BLAKE2B a429684151f5700f148c5350b16026e797fdedc80b950d3c79c050a4d7418763918a05936eaeeed07b9756d9ec39602128570cd8c27049234bbda27e006ff00f SHA512 be445c2c21f5fd0bee241f8f76094b51c2fcbd7fe0d2175f7455beb881c3b83e8070c8a14817695d2b7a7dfabcdb856e12d7749aadc91ca31f7af8187e9a409e
diff --git a/dev-python/textdistance/textdistance-4.6.1.ebuild b/dev-python/textdistance/textdistance-4.6.1.ebuild
new file mode 100644
index 000000000000..bec712f6c5dc
--- /dev/null
+++ b/dev-python/textdistance/textdistance-4.6.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Compute distance between the two texts"
+HOMEPAGE="
+ https://github.com/life4/textdistance/
+ https://pypi.org/project/textdistance/
+"
+SRC_URI="
+ https://github.com/life4/textdistance/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ tests/test_external.py
+)