summaryrefslogtreecommitdiff
path: root/dev-python/textdistance
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-24 23:59:27 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-24 23:59:27 +0100
commitb987a550f067c3da93b0664cf1fdc8a624c0aa38 (patch)
tree9ad1767fad656d26471a81af6bac8400a1c75218 /dev-python/textdistance
parente3f21c8aff8a76afe3423721c437a088e9232840 (diff)
gentoo auto-resync : 24:04:2024 - 23:59:27
Diffstat (limited to 'dev-python/textdistance')
-rw-r--r--dev-python/textdistance/Manifest2
-rw-r--r--dev-python/textdistance/textdistance-4.6.2.ebuild36
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/textdistance/Manifest b/dev-python/textdistance/Manifest
index 76080455d6e4..e96733735a1f 100644
--- a/dev-python/textdistance/Manifest
+++ b/dev-python/textdistance/Manifest
@@ -1,3 +1,5 @@
DIST textdistance-4.6.1.gh.tar.gz 46618 BLAKE2B 168737e2380380570e67e873913823851e6e50a52f5180d4c5519a71f7899074aff2514f0df1a5d920c1c6a8313522fda6eb987862008eda9221ea8cc5be2902 SHA512 a27256c8ad9a228711acb6d54c5ea05634c89537686751c50623411238ee0b519cf0415e345c83b5cd347bda855751562c37ad88f06c1eacfea959cf2798b97c
+DIST textdistance-4.6.2.gh.tar.gz 46619 BLAKE2B 0a205bd5615f252f4ab832597b26cd81f3a817fa9544675b947b2ba8a9d8c128ad261a09fb1ee118e0ca807ff7721f3594de5da11f5df59c90c2d9b7110b84ff SHA512 4e5ec7ef76cfd45b05f5813d624d934a6aa90c326b8bc1af50fdde51c4fda141d5aa826e7a145f4cf59f7d7cbcdcf775746eeb197a2adef3c62ad8570d699890
EBUILD textdistance-4.6.1.ebuild 691 BLAKE2B e50c65401fb60154316c662bc0727beb3cd4fa000e87d4f030ed9c4e552c5c49f1f13788919dd41a42d053da7d166876db99d8485ea918fe784719157fc70459 SHA512 e8897f1ade73f1f3fa12cfdff4edbe597ab86f554ba3eb3f4eed54700f1f413f55a57e423ee33af33cf8264a9f2fd382fa9a183ef6a3c417364fad1576c73066
+EBUILD textdistance-4.6.2.ebuild 694 BLAKE2B 97f7f4a2a1d5c8ec18ce74650b61d48ab977c61c6db2eece3ac7936a5f129653c6fd1ddbba98cc522427c2b20093de567598ea3f57142aa90b2422c72f015531 SHA512 69ab973f974b006b713f9644e9bbacc30d23fbc6c700522ee79551f85e73ea99c0523c547aaf14643d3d9808cadb79625eef24cad6af4df098c41569ff87f45c
MISC metadata.xml 517 BLAKE2B a429684151f5700f148c5350b16026e797fdedc80b950d3c79c050a4d7418763918a05936eaeeed07b9756d9ec39602128570cd8c27049234bbda27e006ff00f SHA512 be445c2c21f5fd0bee241f8f76094b51c2fcbd7fe0d2175f7455beb881c3b83e8070c8a14817695d2b7a7dfabcdb856e12d7749aadc91ca31f7af8187e9a409e
diff --git a/dev-python/textdistance/textdistance-4.6.2.ebuild b/dev-python/textdistance/textdistance-4.6.2.ebuild
new file mode 100644
index 000000000000..e80570bea804
--- /dev/null
+++ b/dev-python/textdistance/textdistance-4.6.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Compute distance between the two texts"
+HOMEPAGE="
+ https://github.com/life4/textdistance/
+ https://pypi.org/project/textdistance/
+"
+SRC_URI="
+ https://github.com/life4/textdistance/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ tests/test_external.py
+)