summaryrefslogtreecommitdiff
path: root/dev-python/textdistance
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-28 23:35:57 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-28 23:35:57 +0100
commit95ea6b4d5731b3430396be650fdb3d4b21cebba1 (patch)
tree8fac22db6af2c5c90106b07a31ee4bbb1ca5faae /dev-python/textdistance
parentbf3704584a111859229f36449fbc925a5a19dc0e (diff)
gentoo auto-resync : 28:09:2023 - 23:35:56
Diffstat (limited to 'dev-python/textdistance')
-rw-r--r--dev-python/textdistance/Manifest2
-rw-r--r--dev-python/textdistance/textdistance-4.6.0.ebuild36
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/textdistance/Manifest b/dev-python/textdistance/Manifest
index c7aec55d99b5..fb406aba4a93 100644
--- a/dev-python/textdistance/Manifest
+++ b/dev-python/textdistance/Manifest
@@ -1,3 +1,5 @@
DIST textdistance-4.5.0.gh.tar.gz 46674 BLAKE2B 5bac2690c48fc518b56f7d781803684c1ccccbb54e62c613f87a58f2acf81d28b405be5ffc41c7a304e62bd19732cdf99a03816c00765698439073b76c5be6c0 SHA512 ae51a2a0b69acd5fd64cab9509ad58713044a1307eee884ecf00508f406a9442414b1d8c71798f2c3ed0e9f5b22cca0a467f6d5a5928510adda43c6997ea497c
+DIST textdistance-4.6.0.gh.tar.gz 46639 BLAKE2B 3d39dfb43c9d3a10ec0c638dd02fd8ee6ccf3d3b06821b8af9331ccfd76a6cae4b33095bd6f71edb670e35a786478f0f7f72baefe4ec3db1a8581a0d8dead4ab SHA512 3e75fde1fc2b0d1dc3917d3860483c5a0aa25affd68c0f05c4888f2404e7e96e6da7b2e581ee3d96626a0a7d4c7ca1e096626224756ec784e72be22681b56116
EBUILD textdistance-4.5.0.ebuild 679 BLAKE2B c47d4333d744a78fc35b19c4687f15afbaabc1bfbd86303c8d8cde984999be638e49b29b607fec0d869c358df676858d54909925138f68aaaed1e1e959ceecfd SHA512 fc9e574749943fb2b2cd9ff36ba0f903c905a6dc15659cb34d89063078b34b2462ca0c5b40125a3631bf8de650e4b83ba43010f011eb201191c3a17fbb2e29b3
+EBUILD textdistance-4.6.0.ebuild 681 BLAKE2B 0d1d14e5a551796eaa3a2a52a7ceccb421d1da1d9f5d1651c7b9bc248c69b154a2e9d6023839604d26595831fed6edecd60f50e703a8c0df25a80f956d067fe8 SHA512 d95f25d7df7ae73c25cd6e0c0384fbfe1a94c721a9a7e7a93d6433e32af68505e3e00c0360c69abf3883442e90d1738bf503b415ab30ddeeaea1ef9432cad9ac
MISC metadata.xml 517 BLAKE2B a429684151f5700f148c5350b16026e797fdedc80b950d3c79c050a4d7418763918a05936eaeeed07b9756d9ec39602128570cd8c27049234bbda27e006ff00f SHA512 be445c2c21f5fd0bee241f8f76094b51c2fcbd7fe0d2175f7455beb881c3b83e8070c8a14817695d2b7a7dfabcdb856e12d7749aadc91ca31f7af8187e9a409e
diff --git a/dev-python/textdistance/textdistance-4.6.0.ebuild b/dev-python/textdistance/textdistance-4.6.0.ebuild
new file mode 100644
index 000000000000..94caef6d9024
--- /dev/null
+++ b/dev-python/textdistance/textdistance-4.6.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Compute distance between the two texts"
+HOMEPAGE="
+ https://github.com/life4/textdistance/
+ https://pypi.org/project/textdistance/
+"
+SRC_URI="
+ https://github.com/life4/textdistance/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~riscv ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ tests/test_external.py
+)