summaryrefslogtreecommitdiff
path: root/dev-python/textdistance
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-19 23:22:40 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-19 23:22:40 +0100
commit4ae4e74a3a13c7c5aaebf61e650538b005204fcb (patch)
tree4abb4271a26b735b28a4eb8b69206cbcc8e7b4e2 /dev-python/textdistance
parentb2a3508c3634488d32ec5bbe6b4365ab27185ebd (diff)
gentoo auto-resync : 19:09:2022 - 23:22:40
Diffstat (limited to 'dev-python/textdistance')
-rw-r--r--dev-python/textdistance/Manifest2
-rw-r--r--dev-python/textdistance/textdistance-4.5.0.ebuild35
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/textdistance/Manifest b/dev-python/textdistance/Manifest
index 71a10645f2e6..7dbf08eb2129 100644
--- a/dev-python/textdistance/Manifest
+++ b/dev-python/textdistance/Manifest
@@ -1,5 +1,7 @@
DIST textdistance-4.3.0.gh.tar.gz 45535 BLAKE2B e43ae62b0b7656a6c4f879b1d8e0c34ae6c83705d324aa99bb7ff6e2d0166faf1fed3ee7bc06602388c16c742a1983a4eaee143b09a7c371b9e941d53edca2b5 SHA512 30d68048b1f0b79e584f5f07731e03193af64cb2de3f52882c17154cc027f4ff8d590b994941bd5d62642d4da334ef0739d4bb65b6b12f039a1ee9aef154cde4
DIST textdistance-4.4.0.gh.tar.gz 45542 BLAKE2B ae144cb7179b589f4106ea378e538e0d0240e6e2ac74dc5de8222ec2f671fcd09c4705cb5b30308fdb2f6071578d337c0f88983511229d9f7eb86c924d65bf56 SHA512 727696b76ee8fdfc9bcf028a93baad38882893f62612fa08725e5e8cd104b9450977e3682995c4aa7d997afcc8fdb73e3c72ea6c1a097a9a19dbce98957d4798
+DIST textdistance-4.5.0.gh.tar.gz 46674 BLAKE2B 5bac2690c48fc518b56f7d781803684c1ccccbb54e62c613f87a58f2acf81d28b405be5ffc41c7a304e62bd19732cdf99a03816c00765698439073b76c5be6c0 SHA512 ae51a2a0b69acd5fd64cab9509ad58713044a1307eee884ecf00508f406a9442414b1d8c71798f2c3ed0e9f5b22cca0a467f6d5a5928510adda43c6997ea497c
EBUILD textdistance-4.3.0.ebuild 816 BLAKE2B f21b515d4df763262ae22f77bf1e720df616869cf24a71b2d3d218a4576f055afcd230cb6ec5a1219968481ef4eaddf686e24b5644f4c0f1553db8d019876712 SHA512 f054497bde2d2e74d6b956ef9c671d8eac321ad8d159fd3151af3c32cd1536470ff6ad5d7283d45745f9f6c8012b732785fa69f600dd0db62134c1cd62a94f60
EBUILD textdistance-4.4.0.ebuild 840 BLAKE2B 8d6e2ee67118d70c73b27cdc7913bde4ce73cf03ed36658a9f94ce9ac21d89d946457777584d5f4496b27b696b99df06867185d51b723a39b44722c0a481188c SHA512 46aeccc5fb7204836c72d26fa069bb5c267f89f908fb05437c76ae946ebb0c73282a87d891a63935bc733efccf1b73984ae44099da3583cce6fc8965f14f5514
+EBUILD textdistance-4.5.0.ebuild 840 BLAKE2B 8d6e2ee67118d70c73b27cdc7913bde4ce73cf03ed36658a9f94ce9ac21d89d946457777584d5f4496b27b696b99df06867185d51b723a39b44722c0a481188c SHA512 46aeccc5fb7204836c72d26fa069bb5c267f89f908fb05437c76ae946ebb0c73282a87d891a63935bc733efccf1b73984ae44099da3583cce6fc8965f14f5514
MISC metadata.xml 517 BLAKE2B a429684151f5700f148c5350b16026e797fdedc80b950d3c79c050a4d7418763918a05936eaeeed07b9756d9ec39602128570cd8c27049234bbda27e006ff00f SHA512 be445c2c21f5fd0bee241f8f76094b51c2fcbd7fe0d2175f7455beb881c3b83e8070c8a14817695d2b7a7dfabcdb856e12d7749aadc91ca31f7af8187e9a409e
diff --git a/dev-python/textdistance/textdistance-4.5.0.ebuild b/dev-python/textdistance/textdistance-4.5.0.ebuild
new file mode 100644
index 000000000000..427ee9e48841
--- /dev/null
+++ b/dev-python/textdistance/textdistance-4.5.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Compute distance between the two texts"
+HOMEPAGE="https://github.com/life4/textdistance"
+SRC_URI="
+ https://github.com/life4/textdistance/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/abydos[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/isort[${PYTHON_USEDEP}]
+ dev-python/jellyfish[${PYTHON_USEDEP}]
+ dev-python/Levenshtein[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pyxDamerauLevenshtein[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ tests/test_external.py
+)