summaryrefslogtreecommitdiff
path: root/dev-python/textdistance
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-python/textdistance
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-python/textdistance')
-rw-r--r--dev-python/textdistance/Manifest3
-rw-r--r--dev-python/textdistance/textdistance-4.2.1-r1.ebuild41
-rw-r--r--dev-python/textdistance/textdistance-4.2.1.ebuild2
3 files changed, 44 insertions, 2 deletions
diff --git a/dev-python/textdistance/Manifest b/dev-python/textdistance/Manifest
index 826a45896259..e8b37435b270 100644
--- a/dev-python/textdistance/Manifest
+++ b/dev-python/textdistance/Manifest
@@ -1,3 +1,4 @@
DIST textdistance-4.2.1.tar.gz 45095 BLAKE2B c0b7fec8adb3a90fc2f3c939a39492887a4989e16d6bd9c548fceb1d5020323d2782dabdb69ae17dc4c3cd795425b3fbdf9bb6041b1ef7df840c2b3a9e2a7e05 SHA512 daff22077800e42ae266edd8614a1300f3f2d080868dbd38e14d035f19853e555485d27ab0392401318e0c4ddc81fbf1b537dd3aa1ba25d7a89e5f0edde8ce46
-EBUILD textdistance-4.2.1.ebuild 1072 BLAKE2B 61cc81dbd396132eff7e85131b605460c42c5a800a039a5b2b9094e8c1c7e3b9c1b2b343eae93c800cc90724fd0a7e36f0bb2bb4a864d412595c206c03327d52 SHA512 eb244b583aabf6ad93c2d105fee8dad0fbb44e4f4548892b9c291127d35d004ef550f93861faade959efa8f76c33ad1b6823ef929c9cc7b658739e864a6ceef3
+EBUILD textdistance-4.2.1-r1.ebuild 1074 BLAKE2B af7b120b00b9256ea3f7f2c39f6177a4fc004336f1ef342fbd47aae44f6a80ca636bf1848a9421f37dd8ca5b8785bb492b736aae25b4223d0199343626440b0c SHA512 8a688c15def007024bbc777890b7dedbc6dc04c3a8ad7415528df46025ad852cccbfdcf9a1dabb55c0080d7204cc4adb69683c4e0cc22679dcdf40742df8a8b8
+EBUILD textdistance-4.2.1.ebuild 1070 BLAKE2B ea01755ffc5dc171ad3c0a192e2f09183835853bc6ca5f79b38bb8da53d1f7afb967e31753262e917efc1ff5c3bdd26d0a524aae345df28dd24be7d9378e7b8e SHA512 98b95403d09f2b70e7061c10239fd704e923181d330e28d22efdff7f1402e851cf01b7556a697823dcda5bfbebf57122b3be75f9547354b763982ce75fc049ae
MISC metadata.xml 562 BLAKE2B 7b2da3e27c8f8870d80a59189ce1025d26f28002882f9e0df47a549c406ae1b074e83196e382d1f1bff17491052e7d2244ab1ae6e022e7159bbab4c63821ff4f SHA512 f3a6544d16475049f713b68196684ab5ecc5e66380460d5dbe7bc0b2ff16fae9f9bc82c1ac6fd215c2d21efb7d89a5d0509a037637ca0ba18c38519d8e8ab0e7
diff --git a/dev-python/textdistance/textdistance-4.2.1-r1.ebuild b/dev-python/textdistance/textdistance-4.2.1-r1.ebuild
new file mode 100644
index 000000000000..3628185a3371
--- /dev/null
+++ b/dev-python/textdistance/textdistance-4.2.1-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Compute distance between the two texts"
+HOMEPAGE="https://github.com/life4/textdistance"
+SRC_URI="https://github.com/life4/textdistance/archive/v.${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="test? (
+ dev-python/abydos[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/isort[${PYTHON_USEDEP}]
+ dev-python/jellyfish[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/python-levenshtein[${PYTHON_USEDEP}]
+ dev-python/pyxDamerauLevenshtein[${PYTHON_USEDEP}]
+)"
+
+S="${WORKDIR}/${PN}-v.${PV}"
+
+distutils_enable_tests --install pytest
+
+python_prepare_all() {
+ # RuntimeError: cannot import distance.hamming
+ # these optional things are missing at the moment
+ sed -i -e 's:test_compare:_&:' \
+ -e 's:test_qval:_&:' \
+ -e 's:test_list_of_numbers:_&:' \
+ tests/test_external.py || die
+
+ distutils-r1_python_prepare_all
+}
diff --git a/dev-python/textdistance/textdistance-4.2.1.ebuild b/dev-python/textdistance/textdistance-4.2.1.ebuild
index 37b4900e0efa..eea667d2ea26 100644
--- a/dev-python/textdistance/textdistance-4.2.1.ebuild
+++ b/dev-python/textdistance/textdistance-4.2.1.ebuild
@@ -13,7 +13,7 @@ SRC_URI="https://github.com/life4/textdistance/archive/v.${PV}.tar.gz -> ${P}.ta
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 x86"
BDEPEND="test? (
dev-python/abydos[${PYTHON_USEDEP}]