summaryrefslogtreecommitdiff
path: root/dev-python/testtools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-31 15:23:38 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-31 15:23:38 +0100
commita407e25d814596ca802d83102671d95e00079767 (patch)
treeb0d4824cf74ddca3ee380c618ffae855cd0d1bcd /dev-python/testtools
parent441510fa20665b7920b149994e72b3a1cd62a813 (diff)
gentoo auto-resync : 31:05:2023 - 15:23:38
Diffstat (limited to 'dev-python/testtools')
-rw-r--r--dev-python/testtools/Manifest1
-rw-r--r--dev-python/testtools/testtools-2.6.0-r1.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/testtools/Manifest b/dev-python/testtools/Manifest
index c8064b947829..25ea5ab07ba0 100644
--- a/dev-python/testtools/Manifest
+++ b/dev-python/testtools/Manifest
@@ -1,3 +1,4 @@
DIST testtools-2.6.0.tar.gz 237864 BLAKE2B 1540c3b6d0f98adccf69e281778cf5ce685cf5b63102f0ee260bc6d1a8cedef0f57a81506e13b705a452f22dd75858da08a7f577b39279b2ae05643b4e96338e SHA512 309893693b2ae63ff75395bf543bd42caa9aee3b1208ce5921d893b3635012f6aa8ed5e797b4d130d83e1b530778e87b91e57b901e8351f86d44f3289d54d04b
+EBUILD testtools-2.6.0-r1.ebuild 1277 BLAKE2B 221bfcb324d6eaaf61b631f9cf2fbb0c21eb4e678edbe4322b2e34e798e5152b07bfab33165e77a72ec592ddf49faa293015642f96da57a2d91eb11000491bec SHA512 58f06e038523a36a13a5e50274afed10acdf0dcb12326618c29309a005ef0dd50c0ede160501ff263d9e3a859e7791287ac2a091d1b41b2423eb7f49df02e616
EBUILD testtools-2.6.0.ebuild 1311 BLAKE2B 0f00fe31d7fe100df195994f61c703d9abed9913e0bccd9c500762abaf6b4611b2ffa6d1bfe8d5cd65090bbd608cb3bf037f783fc5ec13871794b287faf92ba7 SHA512 c0544b9b9003ad56009f511654a3573e64caedab2d519786e17a95e971b315f56193e4c441f5a31222f5c51f89edea86451d3f95d8aaeb9adb9421dd4127db21
MISC metadata.xml 580 BLAKE2B 5068f4abc80612e7a92fb65865612d93cc4d4803a9cda3555cee34eab48da20f6fb22734b09adeaa068cff135d592b5fbd607157a60052a68e127750f6082b24 SHA512 5807608ef5c6d3fa1a86c715c59afb7c4f3913f69739a0c4ea9b6cf85976077280da6ce019ec4fda6dd6bd490379ee0570d5c98f9d719c0cdaf60a550e01e555
diff --git a/dev-python/testtools/testtools-2.6.0-r1.ebuild b/dev-python/testtools/testtools-2.6.0-r1.ebuild
new file mode 100644
index 000000000000..6af5a459caa1
--- /dev/null
+++ b/dev-python/testtools/testtools-2.6.0-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Extensions to the Python standard library unit testing framework"
+HOMEPAGE="
+ https://github.com/testing-cabal/testtools/
+ https://pypi.org/project/testtools/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/pbr-0.11[${PYTHON_USEDEP}]
+ >=dev-python/six-1.4.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/fixtures-2.0.0[${PYTHON_USEDEP}]
+ dev-python/testscenarios[${PYTHON_USEDEP}]
+ dev-python/testresources[${PYTHON_USEDEP}]
+ )
+"
+PDEPEND="
+ >=dev-python/fixtures-2.0.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx doc
+
+src_prepare() {
+ # very fragile to formatting changes (broken on py3.10 & pypy3)
+ sed -i -e 's:test_syntax_error(:_&:' \
+ testtools/tests/test_testresult.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ "${PYTHON}" -m testtools.run testtools.tests.test_suite ||
+ die "tests failed under ${EPYTHON}"
+}