summaryrefslogtreecommitdiff
path: root/dev-python/testtools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-14 18:19:08 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-14 18:19:08 +0000
commit9ecdcfa46d8257a208dac1edc65aea2ccf11a799 (patch)
treeb279d7ba5ed35fb11619b62e48c61254e46ed4a8 /dev-python/testtools
parenta18f8581f716592db51c45679c46e319db13ca29 (diff)
gentoo auto-resync : 14:03:2023 - 18:19:08
Diffstat (limited to 'dev-python/testtools')
-rw-r--r--dev-python/testtools/Manifest2
-rw-r--r--dev-python/testtools/testtools-2.6.0.ebuild53
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/testtools/Manifest b/dev-python/testtools/Manifest
index b7c2bc3b17b1..20cf33e829bc 100644
--- a/dev-python/testtools/Manifest
+++ b/dev-python/testtools/Manifest
@@ -1,4 +1,6 @@
AUX testtools-2.5.0-py311.patch 5238 BLAKE2B 204a5a14a214c18ec62131810d83393789ae290b1430d154eab009e1cfc23a39828ae8a6869cb00dfe529d88d107fae46487ca137489d2adcc9c3f27b5e5d006 SHA512 fbf14268169696608dd2a27ed32ed9fe566b060b9a6d74dc1985199a4ae28267031e0a829f47dc76b46c70ea389aa4296cebb3e8445cc31e2eaaaf117995ce85
DIST testtools-2.5.0.tar.gz 235399 BLAKE2B 62d62cd12f19eb3fad419dc06e7f0152bf8f70a9f60927b1d791f2905b34e13199ceac93b3d30735acae2c5db1e8554cc5a7f6c8588d1f05fb213c424e90a12b SHA512 6adbf9e90f0647a44130e99cd94e4c0cbfab3a1b5c28b6bb124d061defe69d8043186cfe554099936effe16a6b07d59927bfeb6820f5a0fb34970ff243030fd4
+DIST testtools-2.6.0.tar.gz 237864 BLAKE2B 1540c3b6d0f98adccf69e281778cf5ce685cf5b63102f0ee260bc6d1a8cedef0f57a81506e13b705a452f22dd75858da08a7f577b39279b2ae05643b4e96338e SHA512 309893693b2ae63ff75395bf543bd42caa9aee3b1208ce5921d893b3635012f6aa8ed5e797b4d130d83e1b530778e87b91e57b901e8351f86d44f3289d54d04b
EBUILD testtools-2.5.0-r1.ebuild 1502 BLAKE2B 5dbc778d803334ca45b6278023116a3d8a341309a9fe7c411b7aaaa8186cb0821dd5719b173e6e0bed2f87eeee6e609837a85c719407b826e5576918852e05c3 SHA512 1e6188e8691fadbadaa60b94c35c6d4945616c40faa68a07b1e08195a43987b469d5a75480773451af27b291b48a17cbe6e91a055d1f60f082176dc17e7a8c6e
+EBUILD testtools-2.6.0.ebuild 1319 BLAKE2B 5b0cb2ce3ccce64ab4311277edaad7ab262db3741deac34be66760314797ab717e06a4984d3e270089e72299c401c3bc1c7ce2fa80429bd5ac4b16e51b4d45f0 SHA512 679b8c15505a33a3a1591681280916e1b0ad6fd33162e97038f2f8ba691a3211259ebedae86b743428bfdc8693fa8f1fa42c29727cf14355744209d01fb4a40f
MISC metadata.xml 580 BLAKE2B 5068f4abc80612e7a92fb65865612d93cc4d4803a9cda3555cee34eab48da20f6fb22734b09adeaa068cff135d592b5fbd607157a60052a68e127750f6082b24 SHA512 5807608ef5c6d3fa1a86c715c59afb7c4f3913f69739a0c4ea9b6cf85976077280da6ce019ec4fda6dd6bd490379ee0570d5c98f9d719c0cdaf60a550e01e555
diff --git a/dev-python/testtools/testtools-2.6.0.ebuild b/dev-python/testtools/testtools-2.6.0.ebuild
new file mode 100644
index 000000000000..41dc964ff3f9
--- /dev/null
+++ b/dev-python/testtools/testtools-2.6.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Extensions to the Python standard library unit testing framework"
+HOMEPAGE="
+ https://github.com/testing-cabal/testtools/
+ https://pypi.org/project/testtools/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/python-mimeparse[${PYTHON_USEDEP}]
+ >=dev-python/pbr-0.11[${PYTHON_USEDEP}]
+ dev-python/pyrsistent[${PYTHON_USEDEP}]
+ >=dev-python/six-1.4.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/fixtures-2.0.0[${PYTHON_USEDEP}]
+ dev-python/testscenarios[${PYTHON_USEDEP}]
+ )
+"
+PDEPEND="
+ >=dev-python/fixtures-2.0.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx doc
+
+src_prepare() {
+ # very fragile to formatting changes (broken on py3.10 & pypy3)
+ sed -i -e 's:test_syntax_error(:_&:' \
+ testtools/tests/test_testresult.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ "${PYTHON}" -m testtools.run testtools.tests.test_suite ||
+ die "tests failed under ${EPYTHON}"
+}