summaryrefslogtreecommitdiff
path: root/dev-python/testtools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-25 08:44:28 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-25 08:44:28 +0100
commit6d57946e8f20a2294b96eca2e379d3e8e1c93384 (patch)
tree499ffd0e5fb14b9d907fa0d8bb11de0b757c6950 /dev-python/testtools
parent237ad05f4a374a9f1707c3413a5094a6ce93e7ab (diff)
gentoo auto-resync : 25:10:2023 - 08:44:27
Diffstat (limited to 'dev-python/testtools')
-rw-r--r--dev-python/testtools/Manifest1
-rw-r--r--dev-python/testtools/testtools-2.6.0-r2.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/testtools/Manifest b/dev-python/testtools/Manifest
index 1c5f9c638e87..65e9f23394da 100644
--- a/dev-python/testtools/Manifest
+++ b/dev-python/testtools/Manifest
@@ -1,3 +1,4 @@
DIST testtools-2.6.0.tar.gz 237864 BLAKE2B 1540c3b6d0f98adccf69e281778cf5ce685cf5b63102f0ee260bc6d1a8cedef0f57a81506e13b705a452f22dd75858da08a7f577b39279b2ae05643b4e96338e SHA512 309893693b2ae63ff75395bf543bd42caa9aee3b1208ce5921d893b3635012f6aa8ed5e797b4d130d83e1b530778e87b91e57b901e8351f86d44f3289d54d04b
EBUILD testtools-2.6.0-r1.ebuild 1269 BLAKE2B abd28e1b7026dd11d4be94887dc2bbcf67a394b963c3b0e6e40afa2e295b11f88cf011e0363eecd0ba4aefffc3690ec50eeae3e5a92998dadc26ff0766a4f489 SHA512 533ef7990de7db15659820bf4db5cd6ee63f876605a47538c24adfed8095864cb29b3d4f4119eb82b831d5628579ed51b53c944ed1a16ca311cf9df2a9e084c3
+EBUILD testtools-2.6.0-r2.ebuild 1227 BLAKE2B 994d089aede446199f1caea42e1aaa48133de888e1992616691abc511c2794ee7d413027ea4721e255037665a5272c21271f319a1d6e880a35cab673d66e6cb3 SHA512 bc081234c2b44f42341797c5032ef9c0ddc919aac3777b844e72f754792d3d0a3be0832b76aae7f637274cb9869c43900b89e0570869a0507e09040ac0a99865
MISC metadata.xml 580 BLAKE2B 5068f4abc80612e7a92fb65865612d93cc4d4803a9cda3555cee34eab48da20f6fb22734b09adeaa068cff135d592b5fbd607157a60052a68e127750f6082b24 SHA512 5807608ef5c6d3fa1a86c715c59afb7c4f3913f69739a0c4ea9b6cf85976077280da6ce019ec4fda6dd6bd490379ee0570d5c98f9d719c0cdaf60a550e01e555
diff --git a/dev-python/testtools/testtools-2.6.0-r2.ebuild b/dev-python/testtools/testtools-2.6.0-r2.ebuild
new file mode 100644
index 000000000000..c697f34611ea
--- /dev/null
+++ b/dev-python/testtools/testtools-2.6.0-r2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Extensions to the Python standard library unit testing framework"
+HOMEPAGE="
+ https://github.com/testing-cabal/testtools/
+ https://pypi.org/project/testtools/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/pbr-0.11[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/fixtures-2.0.0[${PYTHON_USEDEP}]
+ dev-python/testscenarios[${PYTHON_USEDEP}]
+ dev-python/testresources[${PYTHON_USEDEP}]
+ )
+"
+PDEPEND="
+ >=dev-python/fixtures-2.0.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx doc
+
+src_prepare() {
+ # very fragile to formatting changes (broken on py3.10 & pypy3)
+ sed -i -e 's:test_syntax_error(:_&:' \
+ testtools/tests/test_testresult.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ "${PYTHON}" -m testtools.run testtools.tests.test_suite ||
+ die "tests failed under ${EPYTHON}"
+}