summaryrefslogtreecommitdiff
path: root/dev-python/testscenarios
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
commit9452a6e87b6c2c70513bc47a2470bf9f1168920e (patch)
tree8ac67e26b45f34d71c5aab3621813b100a0d5f00 /dev-python/testscenarios
parentf516638b7fe9592837389826a6152a7e1b251c54 (diff)
gentoo resync : 13.06.2020
Diffstat (limited to 'dev-python/testscenarios')
-rw-r--r--dev-python/testscenarios/Manifest2
-rw-r--r--dev-python/testscenarios/testscenarios-0.5.0.ebuild15
2 files changed, 6 insertions, 11 deletions
diff --git a/dev-python/testscenarios/Manifest b/dev-python/testscenarios/Manifest
index f85e65d0e692..a458aca9310c 100644
--- a/dev-python/testscenarios/Manifest
+++ b/dev-python/testscenarios/Manifest
@@ -1,3 +1,3 @@
DIST testscenarios-0.5.0.tar.gz 20951 BLAKE2B 154915281456aad3353e144ffec8404514622fdeb8d2129ba530d3d5a02814599c2fead9dc25ab4904bad68b2892a435f9cbbcde92503d71477624bbec154f53 SHA512 f08b868babf504482369c5cb945d3e95bca1cc00f92d5013f6898c488051be0c26dc49aaabcef362aea45450a8d041d9826fb6b5c848beec013fb102d6935521
-EBUILD testscenarios-0.5.0.ebuild 1019 BLAKE2B 3f09f25801c5e81b4b8e0436d4e1cfcd208d153e7280199f09f1520d1c9a6e860ab208dc314a199bba6ddf56bd80cef316f71ddc99689653c876b0ecdf8ff02d SHA512 36fd1decce77d4a9d32ffb1c5e943f267a0e3bc48019205a3423e94811ab00aabdb3111c4483b74f4b0251df6d26e114a1df1440b61b9e92a1d18385e8c0e74f
+EBUILD testscenarios-0.5.0.ebuild 882 BLAKE2B 697120873b6c2ce48834a732ed9a8ee5094f5366747af285966de1e4b39a33a8da5635ed582ea98e503df2635379e5de12ae8dba6933938c939d02070e1f7ed5 SHA512 ca59285e82dac99f317fe2eb8a5beec4ae3cae3d9ba8d3d3ea41d114939785ba14805f0bfd94d0a427da635c66b58130c4202970151ba4c494698acc4731e0f7
MISC metadata.xml 979 BLAKE2B ab0d7bfbefdae5ba546ff15669d1caec70e59bf398e6e2ae329821bb141aced038cc946fc309b79a0348051352f7d758e24c081348d6a7e587fc326df14dda09 SHA512 f043d2244673a34d80a88f07c79ac199ad6b2509c3af7a7e934c94330bf745e2dbfbf78fb7f38508cdb1968a87e30cea3e346aad63eb93f94ca762461b3d20e4
diff --git a/dev-python/testscenarios/testscenarios-0.5.0.ebuild b/dev-python/testscenarios/testscenarios-0.5.0.ebuild
index f81da08e2c7f..4c2e3e972ef6 100644
--- a/dev-python/testscenarios/testscenarios-0.5.0.ebuild
+++ b/dev-python/testscenarios/testscenarios-0.5.0.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
+PYTHON_COMPAT=( python2_7 python3_{6..9} pypy3 )
inherit distutils-r1
@@ -22,17 +22,12 @@ RDEPEND="
# using pytest for tests since unittest loader fails with py3.5+
DEPEND="
- ${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/pbr-0.11[${PYTHON_USEDEP}]
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+ >=dev-python/pbr-0.11[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
python_prepare_all() {
# Remove a faulty file from tests, missing a required attribute
rm ${PN}/tests/test_testcase.py || die
distutils-r1_python_prepare_all
}
-
-python_test() {
- pytest -vv || die "Tests fail with ${EPYTHON}"
-}