summaryrefslogtreecommitdiff
path: root/dev-python/testscenarios
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/testscenarios
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/testscenarios')
-rw-r--r--dev-python/testscenarios/Manifest3
-rw-r--r--dev-python/testscenarios/metadata.xml27
-rw-r--r--dev-python/testscenarios/testscenarios-0.5.0.ebuild37
3 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/testscenarios/Manifest b/dev-python/testscenarios/Manifest
new file mode 100644
index 000000000000..d8e1f4c9947f
--- /dev/null
+++ b/dev-python/testscenarios/Manifest
@@ -0,0 +1,3 @@
+DIST testscenarios-0.5.0.tar.gz 20951 BLAKE2B 154915281456aad3353e144ffec8404514622fdeb8d2129ba530d3d5a02814599c2fead9dc25ab4904bad68b2892a435f9cbbcde92503d71477624bbec154f53 SHA512 f08b868babf504482369c5cb945d3e95bca1cc00f92d5013f6898c488051be0c26dc49aaabcef362aea45450a8d041d9826fb6b5c848beec013fb102d6935521
+EBUILD testscenarios-0.5.0.ebuild 1015 BLAKE2B 093b33b4b5496f0fde677719fb3d64934abb711285b8002b6795b719553c55194e4af23e4db8c1337a43e1ae3e52329762f2f88f31cebf8f80faa5385f9d6697 SHA512 5242ccdf2ded6d79e07ad23298b3e668448396bc40f5e526283360dba3d095d5a3a51277e36d29fd4d053f438a036c603a385d307fb669eef05728975ceda048
+MISC metadata.xml 979 BLAKE2B ab0d7bfbefdae5ba546ff15669d1caec70e59bf398e6e2ae329821bb141aced038cc946fc309b79a0348051352f7d758e24c081348d6a7e587fc326df14dda09 SHA512 f043d2244673a34d80a88f07c79ac199ad6b2509c3af7a7e934c94330bf745e2dbfbf78fb7f38508cdb1968a87e30cea3e346aad63eb93f94ca762461b3d20e4
diff --git a/dev-python/testscenarios/metadata.xml b/dev-python/testscenarios/metadata.xml
new file mode 100644
index 000000000000..bfc47ff6cc1f
--- /dev/null
+++ b/dev-python/testscenarios/metadata.xml
@@ -0,0 +1,27 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>openstack@gentoo.org</email>
+ <name>Openstack</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">
+ Testscenarios provides clean dependency injection for
+ python unittest style tests. This can be used for interface testing
+ (testing many implementations via a single test suite) or for classic
+ dependency injection (provide tests with dependencies externally to the
+ test code itself, allowing easy testing in different situations).
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">testscenarios</remote-id>
+ <remote-id type="launchpad">testscenarios</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/testscenarios/testscenarios-0.5.0.ebuild b/dev-python/testscenarios/testscenarios-0.5.0.ebuild
new file mode 100644
index 000000000000..81df8618ccee
--- /dev/null
+++ b/dev-python/testscenarios/testscenarios-0.5.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A pyunit extension for dependency injection"
+HOMEPAGE="https://launchpad.net/testscenarios"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-linux ~x86-linux ~amd64-fbsd"
+IUSE="test"
+
+RDEPEND="
+ dev-python/testtools[${PYTHON_USEDEP}]"
+
+# using pytest for tests since unittest loader fails with py3.5+
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/pbr-0.11[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # Remove a faulty file from tests, missing a required attribute
+ rm ${PN}/tests/test_testcase.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ pytest -vv || die "Tests fail with ${EPYTHON}"
+}