summaryrefslogtreecommitdiff
path: root/dev-python/testscenarios
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:18:26 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:18:26 +0100
commit6c30cc2d5bd48ddbdbe8d75544899cd5dbfcaba4 (patch)
tree6ef7f6e1d48141a5da904d788b906da5bba4b697 /dev-python/testscenarios
parent62f82c107c3904ac6917ece47301d2999c7dd90e (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/testscenarios')
-rw-r--r--dev-python/testscenarios/Manifest2
-rw-r--r--dev-python/testscenarios/testscenarios-0.5.0.ebuild7
2 files changed, 6 insertions, 3 deletions
diff --git a/dev-python/testscenarios/Manifest b/dev-python/testscenarios/Manifest
index b2614be897c7..d8e1f4c9947f 100644
--- a/dev-python/testscenarios/Manifest
+++ b/dev-python/testscenarios/Manifest
@@ -1,3 +1,3 @@
DIST testscenarios-0.5.0.tar.gz 20951 BLAKE2B 154915281456aad3353e144ffec8404514622fdeb8d2129ba530d3d5a02814599c2fead9dc25ab4904bad68b2892a435f9cbbcde92503d71477624bbec154f53 SHA512 f08b868babf504482369c5cb945d3e95bca1cc00f92d5013f6898c488051be0c26dc49aaabcef362aea45450a8d041d9826fb6b5c848beec013fb102d6935521
-EBUILD testscenarios-0.5.0.ebuild 916 BLAKE2B a2a77db6f7c66d0215dea9c9984f5db9c7c7d257d81566887fd99295133cb7efd263810eba4f88a0aed40fd53516b862de1fa6c1b18f2a1bd5358ba9f3d25cd3 SHA512 2b41fede137af8b2220d0ff3d45151b3649a2ca6305e1d8c8a2fa4509e8c3363fc8e77d8ae803558ab2b82f4b0a09790d7593fdc549340ce84a31d27ecfa4b91
+EBUILD testscenarios-0.5.0.ebuild 1015 BLAKE2B 093b33b4b5496f0fde677719fb3d64934abb711285b8002b6795b719553c55194e4af23e4db8c1337a43e1ae3e52329762f2f88f31cebf8f80faa5385f9d6697 SHA512 5242ccdf2ded6d79e07ad23298b3e668448396bc40f5e526283360dba3d095d5a3a51277e36d29fd4d053f438a036c603a385d307fb669eef05728975ceda048
MISC metadata.xml 979 BLAKE2B ab0d7bfbefdae5ba546ff15669d1caec70e59bf398e6e2ae329821bb141aced038cc946fc309b79a0348051352f7d758e24c081348d6a7e587fc326df14dda09 SHA512 f043d2244673a34d80a88f07c79ac199ad6b2509c3af7a7e934c94330bf745e2dbfbf78fb7f38508cdb1968a87e30cea3e346aad63eb93f94ca762461b3d20e4
diff --git a/dev-python/testscenarios/testscenarios-0.5.0.ebuild b/dev-python/testscenarios/testscenarios-0.5.0.ebuild
index 6955aee18da5..81df8618ccee 100644
--- a/dev-python/testscenarios/testscenarios-0.5.0.ebuild
+++ b/dev-python/testscenarios/testscenarios-0.5.0.ebuild
@@ -14,14 +14,17 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-linux ~x86-linux ~amd64-fbsd"
+IUSE="test"
RDEPEND="
dev-python/testtools[${PYTHON_USEDEP}]"
+# using pytest for tests since unittest loader fails with py3.5+
DEPEND="
${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/pbr-0.11[${PYTHON_USEDEP}]"
+ >=dev-python/pbr-0.11[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
python_prepare_all() {
# Remove a faulty file from tests, missing a required attribute
@@ -30,5 +33,5 @@ python_prepare_all() {
}
python_test() {
- "${PYTHON}" -m unittest discover -v || die "Tests fail with ${EPYTHON}"
+ pytest -vv || die "Tests fail with ${EPYTHON}"
}