summaryrefslogtreecommitdiff
path: root/dev-python/testresources
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/testresources
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/testresources')
-rw-r--r--dev-python/testresources/Manifest4
-rw-r--r--dev-python/testresources/metadata.xml1
-rw-r--r--dev-python/testresources/testresources-2.0.1-r2.ebuild (renamed from dev-python/testresources/testresources-2.0.1.ebuild)24
3 files changed, 20 insertions, 9 deletions
diff --git a/dev-python/testresources/Manifest b/dev-python/testresources/Manifest
index 15854fa7b86f..b946405086c2 100644
--- a/dev-python/testresources/Manifest
+++ b/dev-python/testresources/Manifest
@@ -1,3 +1,3 @@
DIST testresources-2.0.1.tar.gz 41948 BLAKE2B 81f597099eb17090cfa759c2fc4e30be2de3f749760e6a0e88e4c5484c91fe6a00d1296ec6ba7dc5aea1bcd0f9239989fab8fbb4f211b6c5bf031ff1be4b803b SHA512 0b23432b019400fe378e957d14a91083eef7fe1130a494b567a5274d69e4e8e09ab75861e5453c3f217507e144cf179c908f84dd1a807992d4bee0b8d32cb0f4
-EBUILD testresources-2.0.1.ebuild 821 BLAKE2B 4071197715cc11cbe986bd6fbcd80c1a9b1239a6cb642078aa5565ad86709bc749caa48e453958e89ba604a46b551a7ade6f0e02163534ad073dfbc9cce50414 SHA512 515250b688ab2aa632c666529ee80f9028c70e60a78de1d891c73ac0ae1baed73dd748af608d66ff00ff7031fce8492320777363cd86d42d195d9448ef71179a
-MISC metadata.xml 940 BLAKE2B 482d6fa661c25db8138eec79df831557f634853374a3bb6080adf0486aa8043092d716cb4fabd3e8cba505afdebf183d83cbd622f2be4d88a0d944e188aa5fcd SHA512 d009ebb49c2d1a28e22edc86aab7c2be5c8ca00261aa3076999680656c68a693be7b953d6d0b32b7213f08d2f3122113d89d50b43e68eb3000136c9cabb1ed51
+EBUILD testresources-2.0.1-r2.ebuild 1002 BLAKE2B d8a9872935b2ddf234c8469f64326e19f093894e4f43ccc06832d547e11e1222a927ed6380c8e2a395b7b720e7948e6a8b7e79b8790f1c8bb0fd1b1f0fedbd3a SHA512 bd90a25af796cdd4cd3f4537e895b011260c87f51dbc3f5235f54ec6431eb7542d589944e8481db3cd959a060e2afc50905f7b90241429935265eb51e1331f38
+MISC metadata.xml 964 BLAKE2B 6857a30f001cc619ed460c6cea5e60e31bb4653a7f5a6b3f357da0dd8649728bb152efd742f2db1541cb283dfda5bb2dc07f8bb61482c6b0522562046b6a5d67 SHA512 b63c926db0afd5d651a8470c9e4e34cd032c83634a067846c91a3ea12649ccd0c3a7990739bb741766b37b739e91078ea367556a84de6eeefcc5ff697424ae9c
diff --git a/dev-python/testresources/metadata.xml b/dev-python/testresources/metadata.xml
index cf54c26c3d00..db9726aac1d4 100644
--- a/dev-python/testresources/metadata.xml
+++ b/dev-python/testresources/metadata.xml
@@ -19,6 +19,7 @@
for example sample working trees for VCS systems, reference databases for
enterprise applications, or web servers ... let imagination run wild.
</longdescription>
+ <stabilize-allarches/>
<upstream>
<remote-id type="pypi">testresources</remote-id>
<remote-id type="launchpad">testresources</remote-id>
diff --git a/dev-python/testresources/testresources-2.0.1.ebuild b/dev-python/testresources/testresources-2.0.1-r2.ebuild
index abee2d1e1311..05d03edf42a8 100644
--- a/dev-python/testresources/testresources-2.0.1.ebuild
+++ b/dev-python/testresources/testresources-2.0.1-r2.ebuild
@@ -3,29 +3,39 @@
EAPI=8
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
inherit distutils-r1
DESCRIPTION="A pyunit extension for managing expensive test resources"
-HOMEPAGE="https://launchpad.net/testresources"
+HOMEPAGE="
+ https://launchpad.net/testresources/
+ https://github.com/testing-cabal/testresources/
+ https://pypi.org/project/testresources/
+"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
+RDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+"
BDEPEND="
dev-python/pbr[${PYTHON_USEDEP}]
test? (
dev-python/testtools[${PYTHON_USEDEP}]
dev-python/fixtures[${PYTHON_USEDEP}]
- )"
+ )
+"
-distutils_enable_tests nose
+distutils_enable_tests unittest
python_prepare_all() {
- sed \
- -e 's:testBasicSortTests:_&:g' \
- -i testresources/tests/test_optimising_test_suite.py || die
+# sed \
+# -e 's:testBasicSortTests:_&:g' \
+# -i testresources/tests/test_optimising_test_suite.py || die
distutils-r1_python_prepare_all
}