summaryrefslogtreecommitdiff
path: root/dev-python/testpath
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-python/testpath
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-python/testpath')
-rw-r--r--dev-python/testpath/Manifest1
-rw-r--r--dev-python/testpath/testpath-0.5.0-r1.ebuild20
2 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/testpath/Manifest b/dev-python/testpath/Manifest
index be6aac41f459..2d81f9abb033 100644
--- a/dev-python/testpath/Manifest
+++ b/dev-python/testpath/Manifest
@@ -1,3 +1,4 @@
DIST testpath-0.5.0.tar.gz 93168 BLAKE2B 864ac80e027192fb1a83f1a15db55fe72729154c7236f2054abfe161be36741614732efbea2a6b4eeb1fb59befa36002d767b4113fab98202ff22330ad15e21d SHA512 d960da04b490b355c5ca9d8e348d81a0d528f13dc7a2b5d6d3c09327a603c1582bce76f7de6d1666b490112306a10d6a19c7979c1119fb726c08c712a08bbcb0
+EBUILD testpath-0.5.0-r1.ebuild 627 BLAKE2B 8ff9cf508e33b6ac3c6f7c933180b27c9dace6a719b080296f8bda06442ed261cba8bd3cc1a7fe6866a35cb3d8ea43310e020de4518b27ca40de2a0ad4419f20 SHA512 7a5ac80e87e32cbae9f24a2362185e62d6ddcdde85e4380f4fdc9f0ef0a7356e107f358480a5993ace86d853b9f79c4712dba507bb445e91258e53407acb09ae
EBUILD testpath-0.5.0.ebuild 678 BLAKE2B f7b345fb3547c9cf65ba2e35248c5b1e8aedbe3475a724357e757bd557ec49c0f29938fcb7b4aa2e16546c3010c30b4cef724c48f94a5342857ca7aabe3036bf SHA512 92ef31c4b1cfa1e7a41ba7b319b579703b747cda4b2b3aa73cd542bc03edc26cc4ef93c43761c2b0ebab863b08b7c91f4fcabc4e6d6e3677f5a654a01aa38725
MISC metadata.xml 765 BLAKE2B be598f7b1de674f7aa6ae377a4f7ba5e52a69fcfaf03e077016425be6471374f4ab1c226fca1454453496fb3d1545f839be7cedadd81b3859eff036cda3fa84a SHA512 017ed9b6be9f7ffbd4754df8d5709111f86fe40da54edb0a67502f9912f3dbb7af2bcf21ea122a210a4dba5e7d451bc88f479f018360b3ec1640c89936d87fa7
diff --git a/dev-python/testpath/testpath-0.5.0-r1.ebuild b/dev-python/testpath/testpath-0.5.0-r1.ebuild
new file mode 100644
index 000000000000..1bd8ec23135b
--- /dev/null
+++ b/dev-python/testpath/testpath-0.5.0-r1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Test utilities for code working with files and commands"
+HOMEPAGE="https://github.com/jupyter/testpath https://testpath.readthedocs.io/en/latest/"
+SRC_URI="https://github.com/jupyter/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc