summaryrefslogtreecommitdiff
path: root/dev-python/testify
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/testify
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/testify')
-rw-r--r--dev-python/testify/Manifest5
-rw-r--r--dev-python/testify/metadata.xml12
-rw-r--r--dev-python/testify/testify-0.11.0.ebuild45
3 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/testify/Manifest b/dev-python/testify/Manifest
new file mode 100644
index 000000000000..a5be7ade1580
--- /dev/null
+++ b/dev-python/testify/Manifest
@@ -0,0 +1,5 @@
+DIST testify-0.11.0.tar.gz 67914 SHA256 04880b44dd34494e498018bf7c0c79370b4f61bee048e2be76068d0a36ab1c82 SHA512 ed19a9b5cfa509b65bfa366aa8c5fb311f00a2996dca9b5028a7dfe8d7ad06ab88964dd7e7ea7aa31e183537d769bbd81eb6dbd7d57d7576b6ec8fca9b684dd0 WHIRLPOOL b855c87cda58b797c47221756580ff5e8db9ef4ebbc30f81bdb34582b2c57bfed49e6c94ee113efa7a83ad73721a0a18263d865ed7d03debf56b9c21a6be368a
+EBUILD testify-0.11.0.ebuild 1314 SHA256 9b45c690ea7c72381b89876c3ca82293698f72428a71583c221ac7f299de5ca5 SHA512 3bce37d90f56ca9b5e505ae7a0d64f8fafaade1ef5774d327e77d46d449cc5de59001497d05d0a8a549fef8da274d5ea88ece6d6dd680ac454b5b75b27a88163 WHIRLPOOL 21d9f0d819001a8edf2731e5ee49ff05fe3e2e2c13c6df50e7e576e945f0b23afee8b10b61f4294c275163d7be42a280ee967716cc99234347696d4812a2b115
+MISC ChangeLog 3688 SHA256 3cf6428c59111ea095888ed2e86aa3c45ba7da597be95c71faeb46aef4bc5130 SHA512 e5386012777a6825e9c7aaf9e7c91161d4b38363031023db356b4aabdc80c14aeed22614d855a873ad69ce86cc24ba313bef280cddca4886f3525eb2aea8f154 WHIRLPOOL fabb17ffeb0ccfd221eaabe01039a3e81f41b7f002ea8fe9c47529fb5d05e29dec470e0806066571802446dc198cc49784d04092612463bbd5628f67099ee34c
+MISC ChangeLog-2015 3526 SHA256 a7af33c5b2fcf34ebae9a55c2f7bd175bca8d27bd7f929aeaa3a968f3fef0bf7 SHA512 7188c3077c9f8550408f24dfc6061f60681437e50ad9f809339649aea366d5827750544121a890fe96e7d7f4c1f7870458195e6194a02b3cf357560c4ab10260 WHIRLPOOL 6c425c310c502b51e9232f34d3a27517286c80b722415725ca3af74499b112d06452c8e21ab5200b2c76bf27a9ea37e8ffc7dda94ad392c52b063f51fe08bf78
+MISC metadata.xml 374 SHA256 88b2412da8d02866e528689831980a6a4593f20c9bc91a39424702449c8dfc13 SHA512 668324c1ff0e2977568abc0ff574acf07d445bb47e17781b7e6d4f409118496c5ab4668ea500e94a615ffcd93c4c5dd59960cb00b886b9c57174ae62ce24c8b0 WHIRLPOOL 982eee52c379b0d3909de3401c7cde488a5c745764c9c739fa969b48ce28af9888e1e5b6c1883db390e8872d0b61042c1770fe90b9944fe263c37448b323054a
diff --git a/dev-python/testify/metadata.xml b/dev-python/testify/metadata.xml
new file mode 100644
index 000000000000..643f2eb0cc32
--- /dev/null
+++ b/dev-python/testify/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">testify</remote-id>
+ <remote-id type="github">Yelp/testify</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/testify/testify-0.11.0.ebuild b/dev-python/testify/testify-0.11.0.ebuild
new file mode 100644
index 000000000000..8887621f2c22
--- /dev/null
+++ b/dev-python/testify/testify-0.11.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="A more pythonic replacement for the unittest module and nose"
+HOMEPAGE="https://github.com/Yelp/testify https://pypi.python.org/pypi/testify/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/sqlalchemy[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ www-servers/tornado[${PYTHON_USEDEP}]
+ >=dev-python/six-1.7.3[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND} )"
+
+python_prepare_all() {
+ # Correct typo in setup.py
+ sed -e 's:mock,:mock:' -i setup.py || die
+
+ # Correct use of local importing in pertinent test_ files
+ sed -e s':from .test:from test:' \
+ -i test/test_runner_test.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ einfo; einfo "Output reporting exceptions \"ImportError: No module named <module>\""
+ einfo "are instances of exceptions expected to be raised, similar to xfails by nose"; einfo""
+ for test in test/test_*_test.py;
+ do
+ "${PYTHON}" $test || die "test $test failed under ${EPYTHON}"
+ done
+}