summaryrefslogtreecommitdiff
path: root/dev-python/testfixtures
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-17 19:04:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-17 19:04:28 +0100
commit514d1bbe260df2521fe60f1a3ec87cfcfde1a829 (patch)
tree555c194dbeb0fb2ac4ad3cde7c0f6a80fd330ce2 /dev-python/testfixtures
parent4df3bf9762850b34cd1ead5c80374d1a0fc3362e (diff)
gentoo resync : 17.07.2021
Diffstat (limited to 'dev-python/testfixtures')
-rw-r--r--dev-python/testfixtures/Manifest2
-rw-r--r--dev-python/testfixtures/testfixtures-6.18.0.ebuild41
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/testfixtures/Manifest b/dev-python/testfixtures/Manifest
index e6b3d5662c90..60caf1b518a1 100644
--- a/dev-python/testfixtures/Manifest
+++ b/dev-python/testfixtures/Manifest
@@ -1,3 +1,5 @@
DIST testfixtures-6.17.1.tar.gz 121440 BLAKE2B 6fcdf4f99af7941044f5f3cdc3e1204b5730d514a009e95f14451537f62af6c6ebaa97356b7ca0dae6313bd81b2a83d981567346e20c477c2d17c6bca73ecdcf SHA512 fbf7c8cd39b83516a257c5a3bce724a8416af88cf1bac8d69457b2030873185c685feb12aea065df2af729a9b733b3e0afe76207bd78e9b5a0c2d464b727d99e
+DIST testfixtures-6.18.0.tar.gz 121584 BLAKE2B abf90012fe79d148c44d72a8aaa5277c95a33933c7b753eecdcaeb11279b4439ad9ea394270e440d9681c22789a17738d367b66adf3d04cf6e6289713c1ead59 SHA512 e6552e6b1837ae4ee4754ce3675bdbf2a68d8e46b892382bd8320290050f2c296348ef6310ce3ff46962bf1978c351fe2cdb853a73c9f800f68818f81d5caec9
EBUILD testfixtures-6.17.1.ebuild 1106 BLAKE2B 2576814009e806ebbe03dfb62b966456fc060146ecafba73010d002a520132184f4056a36754af34dccd9a11464f1d5ec6473970d2cffcf49a115a7616d8de44 SHA512 102be0baf5c3b52fa8a7190fa747e823faeb0ed1e55683d2f99976d384d3bca82dce142340d6cade3d3bceb33c2130cb4ed2f17656edf1265e8c2242f7820b15
+EBUILD testfixtures-6.18.0.ebuild 1109 BLAKE2B 15c8cdcf5b433b32c4138a7d2060db19bbddf192ab326c4a0ae3907026196b3817f2b8c2a75919a69861748abee41ac0c7072508cf10784bfd45feeb1b1f9eaa SHA512 dcd27bff5c81ab2c204dc861a70a0bbf147bd3867bf36baf03401a966a1f33931f272e360c063e717018c10d74f16597707148048bac3911bcb02780519d69a7
MISC metadata.xml 415 BLAKE2B d3e133602f86d013faf5998b2e52256dca88ed9593b9ea26bed0277b70823eda4dd27deca7488a7f66fac2f77e3312cddf833a4b865cf400c7e78a4d267a4c5b SHA512 78fd16b4fd4e8ea3f244b3d8fcce8451a38713d0374df3d2661453f2ad06af587b4613c9119b11bf4cfe3d226fd04620bfa74f58f2660e44ba7e84b93c99c20e
diff --git a/dev-python/testfixtures/testfixtures-6.18.0.ebuild b/dev-python/testfixtures/testfixtures-6.18.0.ebuild
new file mode 100644
index 000000000000..a0872c1838ea
--- /dev/null
+++ b/dev-python/testfixtures/testfixtures-6.18.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="A collection of helpers and mock objects for unit tests and doc tests"
+HOMEPAGE="https://pypi.org/project/testfixtures/ https://github.com/Simplistix/testfixtures"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ dev-python/django[${PYTHON_USEDEP}]
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ dev-python/sybil[${PYTHON_USEDEP}]
+ >=dev-python/twisted-18[${PYTHON_USEDEP}]
+ dev-python/zope-component[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # kill weird way of declaring build deps
+ sed -e '/build=/d' -i setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTHONPATH="."
+ local -x DJANGO_SETTINGS_MODULE=testfixtures.tests.test_django.settings
+ epytest -Wignore::DeprecationWarning
+}