summaryrefslogtreecommitdiff
path: root/dev-python/testfixtures
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-python/testfixtures
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-python/testfixtures')
-rw-r--r--dev-python/testfixtures/Manifest4
-rw-r--r--dev-python/testfixtures/testfixtures-6.18.4.ebuild51
-rw-r--r--dev-python/testfixtures/testfixtures-6.18.5.ebuild51
3 files changed, 106 insertions, 0 deletions
diff --git a/dev-python/testfixtures/Manifest b/dev-python/testfixtures/Manifest
index 6191de1fb384..abb020824947 100644
--- a/dev-python/testfixtures/Manifest
+++ b/dev-python/testfixtures/Manifest
@@ -1,4 +1,8 @@
AUX testfixtures-6.18.1-py3.10.patch 6506 BLAKE2B 09db867dfaf8b76098681ce2b74731a8224b54e72b96362a34187e3e55309095bac8459d40b3c54fc6cedebe13c9f76ac9cc18ff43c2bf9e88b9dbfa369dff5a SHA512 d91b46005525cbefa2100eee25720b1229c6ca8213aaf36578635ffc82edc50aeef278d8e009d13bdb14ab791d7969b5fd39ae70fb2becce8f255edee1256792
DIST testfixtures-6.18.3.tar.gz 122142 BLAKE2B 014cc2245d5fbe0d39310c8e2c21cd5f289d6ec7a6a561d055e86d4cd25b79f1aa535067746219e2382df2aeec050dfa24cdae674636d92ee61016fa9861e705 SHA512 e556e7cb28f122526ef19550b1e593b61f01923d0be53951344f917f89b3d4cae29e525ceda3d0290bc18c3641b509dd7236e7b55ae50da0157fe11ca9f04cca
+DIST testfixtures-6.18.4.tar.gz 124910 BLAKE2B 8c19672903d3b6ba5139b95f1d060c0d71ae8891e8c190a8891fded6d79af3549a91809b73a114f69cf2b0de49740e49a9e38e44981addcd09d7b4c343ea3ced SHA512 2643ddfd7c4be7b514070e2df8e52479ad51f50a8b69507faf36d90bd92aa0201f1c3033eb00e644bac194601b0a9190c02727f18d899629ab09abfa3546ecd7
+DIST testfixtures-6.18.5.tar.gz 124944 BLAKE2B 6f1431b3e7201a3c12bf683cfcb123329b186f42a64fdfe3ee7897ab0c5e9ba3995deb88934ae59f0d35b64710ac04b421d07f1c496429b18a0b6a03e600885d SHA512 4d4ec7295bb056102995dc1c872b86059109b114ab921769d3aa2c2de96a3789fef30558f51826655b6d2d668ea1b1bc9f161a4584aab628f59d4da1fa95940e
EBUILD testfixtures-6.18.3.ebuild 1262 BLAKE2B ccc00540e6492949a0755223af5b40813c4c15319b4d13a797d884bff52be2e2a7ec88d2257946174fc7818ff4bb54309e30eabff7337d4ce00cb097a647c23d SHA512 1100995ba017e4b626d0a7806db5704115af9bacfa852e5f97e00f1f8598531e2af189b1a418ba0dfa7d49aa97a0f821d647475f54893f7f9d4d279efd8d98a5
+EBUILD testfixtures-6.18.4.ebuild 1311 BLAKE2B 62614aba8e5939f210dfd3b8b3fbe8108acbc24336a5936686a3ed1ea132126e18559d564cf2884b32c46f0b730785b60499a90a041c6d16a40bbb14264c27fd SHA512 2d548b941f16a1bc7ccc0a6548773cbf2c6e8156443b1c783bc667d9940c8298794781564ad318b55eaf6c28f3ebbdf17b53633a9429596cf0aeaac7a8fdcbce
+EBUILD testfixtures-6.18.5.ebuild 1311 BLAKE2B 62614aba8e5939f210dfd3b8b3fbe8108acbc24336a5936686a3ed1ea132126e18559d564cf2884b32c46f0b730785b60499a90a041c6d16a40bbb14264c27fd SHA512 2d548b941f16a1bc7ccc0a6548773cbf2c6e8156443b1c783bc667d9940c8298794781564ad318b55eaf6c28f3ebbdf17b53633a9429596cf0aeaac7a8fdcbce
MISC metadata.xml 416 BLAKE2B 19f5d275458874364d2719ecf363f7a5627f9e612b7d3a3f2c075e306063ed899dec0b2e59ea5e5d7ba65209c9a6d91045d80b2fe50e74278e61247d0426b940 SHA512 8a5776feee4d6758da67dc0b413e2d0ddc0c843075ca96c9b44adace1f7669a6abf820c5b73b86652b27e9feed19a4a30e1004a021b24bda0829b5690a1687ec
diff --git a/dev-python/testfixtures/testfixtures-6.18.4.ebuild b/dev-python/testfixtures/testfixtures-6.18.4.ebuild
new file mode 100644
index 000000000000..8755772cbbc7
--- /dev/null
+++ b/dev-python/testfixtures/testfixtures-6.18.4.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A collection of helpers and mock objects for unit tests and doc tests"
+HOMEPAGE="https://pypi.org/project/testfixtures/ https://github.com/Simplistix/testfixtures"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ dev-python/django[${PYTHON_USEDEP}]
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ dev-python/sybil[${PYTHON_USEDEP}]
+ >=dev-python/twisted-18[${PYTHON_USEDEP}]
+ dev-python/zope-component[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # kill weird way of declaring build deps
+ sed -e '/build=/d' -i setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTHONPATH="."
+ local -x DJANGO_SETTINGS_MODULE=testfixtures.tests.test_django.settings
+
+ local EPYTEST_DESELECT=(
+ # TODO
+ testfixtures/tests/test_shouldwarn.py::ShouldWarnTests::test_filter_missing
+ testfixtures/tests/test_shouldwarn.py::ShouldWarnTests::test_filter_present
+ )
+
+ epytest
+}
diff --git a/dev-python/testfixtures/testfixtures-6.18.5.ebuild b/dev-python/testfixtures/testfixtures-6.18.5.ebuild
new file mode 100644
index 000000000000..8755772cbbc7
--- /dev/null
+++ b/dev-python/testfixtures/testfixtures-6.18.5.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A collection of helpers and mock objects for unit tests and doc tests"
+HOMEPAGE="https://pypi.org/project/testfixtures/ https://github.com/Simplistix/testfixtures"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ dev-python/django[${PYTHON_USEDEP}]
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ dev-python/sybil[${PYTHON_USEDEP}]
+ >=dev-python/twisted-18[${PYTHON_USEDEP}]
+ dev-python/zope-component[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # kill weird way of declaring build deps
+ sed -e '/build=/d' -i setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTHONPATH="."
+ local -x DJANGO_SETTINGS_MODULE=testfixtures.tests.test_django.settings
+
+ local EPYTEST_DESELECT=(
+ # TODO
+ testfixtures/tests/test_shouldwarn.py::ShouldWarnTests::test_filter_missing
+ testfixtures/tests/test_shouldwarn.py::ShouldWarnTests::test_filter_present
+ )
+
+ epytest
+}