summaryrefslogtreecommitdiff
path: root/dev-python/test_server/test_server-0.0.31.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-21 23:14:26 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-21 23:14:26 +0100
commit7c59acba5699c9c58090a7a738669669a7307023 (patch)
treed51d27d020895a6b7a3298d9d1b9846c1fcb59a0 /dev-python/test_server/test_server-0.0.31.ebuild
parente2db47eaae00ec33f8971db44b68645c5d3b9590 (diff)
gentoo resync : 21.08.2021
Diffstat (limited to 'dev-python/test_server/test_server-0.0.31.ebuild')
-rw-r--r--dev-python/test_server/test_server-0.0.31.ebuild22
1 files changed, 7 insertions, 15 deletions
diff --git a/dev-python/test_server/test_server-0.0.31.ebuild b/dev-python/test_server/test_server-0.0.31.ebuild
index 720653069947..7767107a8591 100644
--- a/dev-python/test_server/test_server-0.0.31.ebuild
+++ b/dev-python/test_server/test_server-0.0.31.ebuild
@@ -1,9 +1,9 @@
-# Copyright 2019-2020 Gentoo Authors
+# Copyright 2019-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7,8} pypy3 )
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
inherit distutils-r1
DESCRIPTION="Server to test HTTP clients"
@@ -13,22 +13,14 @@ SRC_URI="https://github.com/lorien/test_server/archive/v${PV}.tar.gz -> ${P}.tar
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
RDEPEND="
>=dev-python/bottle-0.12.13[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
dev-python/webtest[${PYTHON_USEDEP}]"
-distutils_enable_tests pytest
-
-src_prepare() {
- distutils-r1_src_prepare
+PATCHES=(
+ "${FILESDIR}/${P}-fix-py3.10.patch"
+)
- # broken on py2.7, upstream knows
- sed -i -e '5a\
-import sys' \
- -e '/test_null_bytes/i\
-@pytest.mark.skipif(sys.hexversion < 0x03000000, reason="broken on py2")' \
- test/server.py || die
-}
+distutils_enable_tests pytest