summaryrefslogtreecommitdiff
path: root/dev-python/test_server/test_server-0.0.31.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /dev-python/test_server/test_server-0.0.31.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'dev-python/test_server/test_server-0.0.31.ebuild')
-rw-r--r--dev-python/test_server/test_server-0.0.31.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/test_server/test_server-0.0.31.ebuild b/dev-python/test_server/test_server-0.0.31.ebuild
new file mode 100644
index 000000000000..823107ea4a80
--- /dev/null
+++ b/dev-python/test_server/test_server-0.0.31.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
+inherit distutils-r1
+
+DESCRIPTION="Server to test HTTP clients"
+HOMEPAGE="https://github.com/lorien/test_server https://pypi.org/project/test-server/"
+SRC_URI="https://github.com/lorien/test_server/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/bottle-0.12.13[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/webtest[${PYTHON_USEDEP}]"
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # broken on py2.7, upstream knows
+ sed -i -e '5a\
+import sys' \
+ -e '/test_null_bytes/i\
+@pytest.mark.skipif(sys.hexversion < 0x03000000, reason="broken on py2")' \
+ test/server.py || die
+}