summaryrefslogtreecommitdiff
path: root/dev-python/terminaltables/terminaltables-3.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-07-10 23:40:16 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-07-10 23:40:16 +0100
commit51af5f0eb4cddbe6aa7953717873691d77aae9ff (patch)
tree1541525274162b033ebbc3ed38abaf335fbbd49a /dev-python/terminaltables/terminaltables-3.1.0.ebuild
parent7014a5a3ea0feffab9701fdd6b64cc7667a985af (diff)
gentoo resync : 11.07.2019
Diffstat (limited to 'dev-python/terminaltables/terminaltables-3.1.0.ebuild')
-rw-r--r--dev-python/terminaltables/terminaltables-3.1.0.ebuild23
1 files changed, 17 insertions, 6 deletions
diff --git a/dev-python/terminaltables/terminaltables-3.1.0.ebuild b/dev-python/terminaltables/terminaltables-3.1.0.ebuild
index 7c1b9f0d30de..851902172a43 100644
--- a/dev-python/terminaltables/terminaltables-3.1.0.ebuild
+++ b/dev-python/terminaltables/terminaltables-3.1.0.ebuild
@@ -1,18 +1,29 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
inherit distutils-r1
DESCRIPTION="Generate simple tables in terminals from a nested list of strings"
-
HOMEPAGE="https://robpol86.github.io/terminaltables"
SRC_URI="https://github.com/Robpol86/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND=""
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/colorclass[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/termcolor[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ pytest -vv || die "Tests fail with ${EPYTHON}"
+}